Why can't I log out of Jira?

When I click the Log out, the screen refreshes and I am not logged out.

5 answers

This widget could not be displayed.

That sounds very strange.   I'd be interested to see if you can directly visit your https://[your_cloud_address].atlassian.net/logout/

in order to try to logout instead.  If that doesn't seem to work could you try to browse to https://id.atlassian.com and see if you can use the Log out button in the top right corner of that screen.

If that too doesn't work, I think the next steps I would recommend would be to clear both the browser cookies and cache and restart the browser. 

Just curious which browser are you using?   Wondering if this is something you can repeat in different browsers, such as Chrome, Firefox, Safari, IE, etc.

Please let us know.

Andy

This widget could not be displayed.

I've seen this happen with a couple of browsers that have automatic login enabled (internally or via password-safe software, which you really should be using) - the browser is logging you back in when it detects the log in screen.  Better browsers will detect the logout and not do it, and better password-safe software allows you to disable it.

As Andrew suggests, a different browser, with a clean cache, should show you if this is a possible cause.

I think this could be the answer. I will check about disabling the auto-login. I am using Windows 10 (Chrome 62). 

I was able to logout after the first time I logged in. After that, it went into the loop.

This widget could not be displayed.

Having this exact issue with IE 11
Version: 11.0.9600.18838
No additional browser extensions or addons installed.


Happens within the cloud instances, atlassian sites (id.atlassian.com, community.atlassian.com, etc) and from the Atlassian page that displays when you try to log into an instance with the wrong account, that offers to let you switch accounts. It continues to try to log in with that last account used.

Currently, browsing to some other page, like google.com and clearing all cached browser information, will then allow me to return to the instance or page and log in with correct account

Currently checking other sources to see if there are settings within IE that are allowing for the persistence of authentication data.

Issue is not occurring when using Chrome.
Version 62.0.3202.94 

This widget could not be displayed.

I just thought I'd chime in as this seems to be happening for me too - using Safari and Keychain password. 

This widget could not be displayed.

Me too, with id.atlassian.com using Chrome (I even tried an incognito window, with the same result). The Chrome debugger console showed this error:

Failed to load https://id.atlassian.com/logout?application=sac&mode=cloud&continue=https%3A%2F%2Fsupport.atlassian.com: Response to preflight request doesn't pass access control check: No 'Access-Control-Allow-Origin' header is present on the requested resource. Origin 'https://getsupport.atlassian.com' is therefore not allowed access. The response had HTTP status code 405. 

Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Posted Wednesday in New to Jira

Are you planning to trial, or are currently trialling Jira Software? - We want to talk to you!

Hello! I'm Rayen, a product manager at Atlassian. My team and I are working hard to improve the trial experience for Jira Software Cloud. We are interested in   talking to 20 people planning t...

148 views 2 0
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you