Why am I getting a malformed Jira URL?

Some times when I navigate within Jira, or type in my jira URL (http://jira.example.com/) I will get an error that looks like it's due to a malform URL redirection (https://jira.example.comsecure/Dashboard.jspa). Note that there is a missing slash between ".com" and "secure". I have Apache2 sitting in front of Jira acting as a reverse proxy. Any ideas about the missing slash in the URL. I'm running Jira 5.2.5.

5 answers

1 accepted

0 votes
Accepted answer

This seemed to only happen when I had my virtual host file for Confluence enabled; this was with Confluence 4.3. When I only had Jira's virtual host file enabled, I would not get this error. I ended up uninstalling Confluence 4.3, and thought I would just wait for Confluence 5.0 to come out and try it. I installed Confluence 5.0 and have its virtual host file enabled, and now I'm not getting the error. It could be coincidence, and the problem was something else, but if anyone else is getting the same error, and have a similar setup, you might want to try installing version 5 of Confluence.

What's your BaseUrl? Does this happen when you access Jira without the reverse proxy?


I can't test whether this happens without the reverse proxy at the moment; I'm not on the private network, and the firewall would prevent me from hitting Jira directly. The error could be in the Apache configuration, but I'm not sure what would be incorrect. Here's the virtual host file:

<VirtualHost *:80>
ServerName jira.example.com
ServerAdmin email@example.com
Redirect permanent / https://jira.example.com/

ServerAdmin email@example.com

<Proxy *>
Order deny,allow
Allow from all

SSLProxyEngine On
SSLCertificateFile <path to cert>
SSLCertificateKeyFile <path to key>

ProxyRequests Off
ProxyPreserveHost On
ProxyPass / http://localhost:8080/<br< a="">> ProxyPassReverse / http://localhost:8080/

<br< a="">>

I'm having the same problem, jira works fine if accessed via localhost:8080. But if I try to acces via a reverse proxy http://jira.example.com or https://jira.example.com (all http is redirected to https) I get an error saying that jira.example.comsecure could not be reached. thsi is very strange as this only started after updating jira from 5.1.6 to 5.2.7

I'm not having this problem any longer, but from what I can remember, I would only get this error when I also had my virtual host enabled for Confluence 4.3. In this case I would get the malformed URL for both Jira (5.2) and Confluence. Since then I have installed Confluence 5.0, and it's working fine. I don't know if it was an issue with my virtual host files that have since been fixed, or an issue with the two running together. If you have another virtual host file for Confluence, you might try to disable it as part of trouble-shooting.

Sorry to reactivate a cold thread.

I had the same problem tonight.

What put me on the trail is "http is redirected to https". I have the same configuration.

Hence you should had a trailing slash on you r http to https redirection :

Redirect / https://jira.myhost.fr/

Hope this helps anyone having the same issue.

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Nov 27, 2018 in Portfolio for Jira

Introducing a new planning experience in Portfolio for Jira (Server/DC)

In the past, Portfolio for Jira required a high degree of detail–foresight that was unrealistic for many businesses to   have–in   order to produce a reliable long-term roadmap. We're tur...

2,647 views 18 21
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you