Why Epics do not appear in my kanban backlog?

Mark Collins
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
March 15, 2019

Hello! Using Jira cloud, and trying to set up a new Kanban Project with a backlog. However, the Epic pane does not appear. (first image). The Epics somehow to appear in line with the stories (second image). (The data was migrated from another project)

Our Jira is very poorly set up. Any ideas?

I did notice the Epics are 'locked' but unsure what this means or how to change it. (refer to the third mage)

RMP board   Agile Board   RedMarker JIRA (1).pngRMP board   Agile Board   RedMarker JIRA (2).pngProject Red Marker Planning   Fields   RedMarker JIRA.png

5 answers

1 accepted

9 votes
Answer accepted
Mark Collins
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
March 15, 2019

Closed :) (by me) 

The Epics Panel needs to be 'ticked'

RMP board   Agile Board   RedMarker JIRA (3).png

Alina Zhoga
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
June 20, 2019

Could be too late, though might be helpful to others - if epics do not show, check the filter settings (Board settings > General > Filter > Edit filter query), could be that some users that are assigned to these Epics are not ticked or the Epics are not ticked in the statuses.

Like # people like this
8 votes
Andrei Navroschi February 10, 2022

Here is what happened in my case. We have migrated from Jira Server to Jira Cloud.
It appears that by default the Epic Panel was enabled, but it was not visible because the board in question didn't have a backlog. So, the idea is to enable the backlog, disable the option, disable the backlog back, et voila.


Here are the steps:
1. Access Columns in Board Settings
2. Drag an existing status on Kanban backlog column(the last on the left side); this will enable the backlog and option "Epic Panel".
3. Disable Epic Panel; at this point you can check and see that the epics are back.
4. Put the status from Backlog column back to the original column; This will disable the backlog. That's it.

 

Hope it helps.

JLevin
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
April 4, 2022

I hit exactly this issue too.  Thanks for the solution.

Like Carina De Almeida likes this
4 votes
Lilian_Hayrapetian
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
May 26, 2020

for me issue was because of my board was filtered by a label and while creating the epic I was not assigning that label to my epic link. 

Mine Esen January 8, 2021

Ah, mine was the same. Thank you for pointing this out. You saved me a lot of time!

Jim Lile July 23, 2021

there is no EPIC panel 
Button to click in my Columns board settings. any suggestions? I tried the filter but what I want is simply for EPICs to Appear by Versions in the Backlog

Wupadrasta Subbarao
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
May 8, 2024

@Lilian_Hayrapetian Thank you for the inputs. It helped me

2 votes
Prasuna Hemanth Raj
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
July 16, 2020

When I turn on display epics, I am seeing the epics panel, but the epics are not showing up on that panel. How can I fix that?

RMP board   Agile Board   RedMarker JIRA (3).png

Imran Khan
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
July 22, 2020

I didn't see my epics appear because I missed adding "Epic" issue type in my filter query.

Now I can see my epics.

 

Please check if your filter query is proper?

Like # people like this
Domingos Vargas
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
July 14, 2021

Thanks Imran! It worked for me!

Ellen Braga
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
July 14, 2021

Perfect! Thanks ;)

Leena Siddamshetty February 1, 2022

I am also facing the same issue but on Scrum board. Can anyone help please? When i set board configuration to Swimlanes=Epic, it does not shows epics but without it "No swimlanes" epic are visible. Belo is the filter for my board:

 

project = XXXX AND (component = YYY OR Team = CCC) AND issuetype in (Epic, Bug, Task, Story, Spike, Sub-task) ORDER BY Rank ASC

0 votes
Damien Wieman
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
February 12, 2024

From the kanban board, I went to three dots:
... -> Columns 

There is an Epic issues title, with two options.

I changed mine from "Display as cards on the board" to "Display in Epic panel on the Backlog"


Then back in the Kanban board, I once more had an option to show the epic panel

Suggest an answer

Log in or Sign up to answer
TAGS
AUG Leaders

Atlassian Community Events