Web Resource Plugin Module - cache problem

Hi Guys.

I have own Plugin with JavaScript code automatically sets the contents of the Summary

depends on settings in another fields. This one working OK, but problem starts

if I do some changes in javasctipt code, build, install...

then all working like before changes, but if I press CRTL-F5 (refresh)

then new one starts working.

How can I solve this cache problem?

Thanks for any help

Regards

Mik

1 answer

This happens for the fresh build of script based plugins. so you are required to refresh the issue page(which is already present )to get the latest details. After the plugin deployed, if you are trying to create the new issue, there itself the changes take place. If not happening so, then it is a problem.

Hope understand. If I'm mis-interpreted you can re-ask your problem.

Hi Bharadwaj

This happens ( after new version installation ) - on my custommer web browser.

Old javascript is still there - to the moment when he presses CTRL-F5.

After he presses CTRL-F5 - all is ok.

Regards

Mik

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Published Thursday in Jira

5 ways you can make the most of Jira Software and Bitbucket Cloud

As part of the Bitbucket product team I'm always interested in better understanding what kind of impact the use of our tools have on the way you work. In a recent study we conducted of software devel...

90 views 0 5
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you