Web Resource Plugin Module - cache problem

Hi Guys.

I have own Plugin with JavaScript code automatically sets the contents of the Summary

depends on settings in another fields. This one working OK, but problem starts

if I do some changes in javasctipt code, build, install...

then all working like before changes, but if I press CRTL-F5 (refresh)

then new one starts working.

How can I solve this cache problem?

Thanks for any help

Regards

Mik

1 answer

This happens for the fresh build of script based plugins. so you are required to refresh the issue page(which is already present )to get the latest details. After the plugin deployed, if you are trying to create the new issue, there itself the changes take place. If not happening so, then it is a problem.

Hope understand. If I'm mis-interpreted you can re-ask your problem.

Hi Bharadwaj

This happens ( after new version installation ) - on my custommer web browser.

Old javascript is still there - to the moment when he presses CTRL-F5.

After he presses CTRL-F5 - all is ok.

Regards

Mik

Suggest an answer

Log in or Join to answer
Community showcase
Sarah Schuster
Posted Jan 29, 2018 in Jira

What are common themes you've seen across successful & failed Jira Software implementations?

Hey everyone! My name is Sarah Schuster, and I'm a Customer Success Manager in Atlassian specializing in Jira Software Cloud. Over the next few weeks I will be posting discussion topics (8 total) to ...

2,760 views 11 18
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot