Very slow authentication to JIRA 5.2 with Crowd 2.5.2

I am running JIRA 5.2 with authentication through Crowd 2.5.2. Both running on one server.

But login to JIRA is very slow (about 30 - 60 seconds). Once a session for user in Crowd is created, everything runs smoothly. According to logs the problem should be in application authentication, not a user authentication.

Do you have any clue how to solve this?

Thanks

Petr

---

Crowd log: see 60 seconds took to authenticate JIRA application:

2012-11-30 09:19:33,837 http-8083-6 DEBUG [crowd.manager.validation.ClientValidationManagerImpl] Client address: 127.0.0.1

2012-11-30 09:19:33,839 http-8083-6 DEBUG [atlassian.util.profiling.UtilTimerStack] [1ms] - PropertyManager.isCacheEnabled()

--- Here comes 60 seconds leak ---

2012-11-30 09:20:33,327 http-8083-6 DEBUG [plugin.rest.filter.BasicApplicationAuthenticationFilter] Application 'jira-kitdcs' is already authenticated

2012-11-30 09:20:33,334 http-8083-6 DEBUG [atlassian.util.profiling.UtilTimerStack] [2ms] - ApplicationManager.findByName()

5 answers

Thanks, I tried this link but it didn't help. Problem is still occuring, even if I switch to SSO.

In an administration of crowd I am not able to see in current sessions logged aplications for JIRA and Confluence. Even if I log in through them. I only see there Crowd application.

Any suggestions where to look for the problem? Thanks.

Hi Petr,

There are a lot of moving parts in your question: What is crowd backed by ? Is this just an internal crowd directory, or is Crowd connecting to an external authentication source?

If so, how is it configured? Is it a delegated authentication directory or are you synchronizing? If there is an external directory, what is it, and how large is it?

I can understand if these questions are a bit more sensitive: If posting answers to the above questions into a public forum is bothersome, I'd suggest opening a support ticket at support.atlassian.com: we can help you privately if that would be preferable.

Tim

Hi Tim,

sorry for my delay, but a problem is still occuring, so I will specify details a little bit.

Firstly - its all small apps (hundreds of users). I do not sync Crowd with any external directory so it uses internal directory. Jira and Confluence uses synchronization (not delegated auth).

If I turn profiling on in Crowd, the responses seems to be OK. But if I turn profiling in Confluence (or Jira) something like this appears:

2013-03-12 14:38:10,971 DEBUG [http-9091-4] [atlassian.util.profiling.UtilTimerStack] log [29956ms] - /dologin.action

[0ms] - UserAccessor.getUser()

[29947ms] - UserAccessor.authenticate()

[1ms] - UserAccessor.getUser()

[0ms] - UserAccessor.getUser()

You see - the part UserAccessor.authenticate() takes super long time to run. If I tried other Jira instalation (just connect it to Crowd) ... the same problem occured. I am running new Jira = 5.2 and new Crowd = 2.5.2. If I run administration of Crowd it seems to run very fast and having no trouble at all (also the login to Crowd is very fast).

Another interesting thing - it occurs only on the first login to Jira and Confluence. Than auth is cached in crowd and it responds very fast). But the first log in is super slow.

Do you have any clues what should I try?

thanks a lot!

petr

Same issue here? Any thoughts?

Same issue! Can anyone help us ?

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Nov 27, 2018 in Portfolio for Jira

Introducing a new planning experience in Portfolio for Jira (Server/DC)

In the past, Portfolio for Jira required a high degree of detail–foresight that was unrealistic for many businesses to   have–in   order to produce a reliable long-term roadmap. We're tur...

2,650 views 18 21
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you