Upgrade error: JIRA is unable to migrate the User Directory....

Me again,

Attempting to upgrade from 4.1.2 to 4.4.5... Now the problem I'm having is with the osuser.xml file. Jira says "the osuser.xml file does not contains a recognized configuration..." I've seen the previous tickets about this and added the internal providers as recommended. Can anyone tell me what else is wrong with this file?? Here are some excerpts:

<opensymphony-user>

<authenticator class="com.opensymphony.user.authenticator.SmartAuthenticator" />
- <provider class="com.opensymphony.user.provider.ldap.LDAPCredentialsProvider">
<property name="java.naming.factory.initial">com.sun.jndi.ldap.LdapCtxFactory</property>
<property name="cacheTimeout">30</property>
<property name="url">ldap://localhost:389</property>
<property name="searchBase">o=GNISE</property>
<property name="uidAttribute">uid</property>
<property name="memberOfAttribute">uniqueSystemRoleMember</property>
<property name="attributeMap">email=mail,fullName=cn</property>
<property name="staticGroups">jira-users</property>
- <property name="groupMap">
jira-administrators='rn=jira-administrators,ou=roles,an=JIMS,ou=applications,o=GNISE'
</property>
<property name="principal">o=GNISE</property>
<property name="credentials">password</property>
<property name="useTls">false</property>
<property name="serverDateFormat">yyyyMMddHHmmss'.0Z'</property>
<property name="exclusive-access">true</property>
</provider>
<provider class="com.atlassian.core.ofbiz.osuser.CoreOFBizCredentialsProvider">
<property name="exclusive-access">true</property>
</provider>
<provider class="com.opensymphony.user.provider.ofbiz.OFBizProfileProvider">
<property name="exclusive-access">true</property>
</provider>
<provider class="com.opensymphony.user.provider.ofbiz.OFBizAccessProvider">
<property name="exclusive-access">true</property>
</provider>
<provider class="com.atlassian.jira.user.osuser.JiraOFBizCredentialsProvider">
<property name="exclusive-access">true</property>
</provider>
<provider class="com.atlassian.jira.user.osuser.JiraOFBizProfileProvider">
<property name="exclusive-access">true</property>
</provider>
<provider class="com.atlassian.jira.user.osuser.JiraOFBizAccessProvider">
<property name="exclusive-access">true</property>
</provider>
</opensymphony-user>

1 answer

1 accepted

Hi there,

The message "the osuser.xml file does not contains a recognized configuration" refers to this KB article, but I believe that what is happening is that you have more lines than the default into your osuser.xml and JIRA is failing to process this information.

I'd suggest to test the upgrade using only the default lines, as the example bellow:

&lt;opensymphony-user&gt;
     &lt;authenticatorclass="com.opensymphony.user.authenticator.SmartAuthenticator" /&gt;
     &lt;provider class="com.opensymphony.user.provider.ldap.LDAPCredentialsProvider"&gt;
     &lt;property name="java.naming.factory.initial"&gt;com.sun.jndi.ldap.LdapCtxFactory&lt;/property&gt;
     &lt;property name="java.naming.provider.url"&gt;ldap://10.60.x.xxx:3268&lt;/property&gt;
     &lt;property name="searchBase"&gt;dc=xxxxxxxx,dc=internal&lt;/property&gt;
     &lt;property name="uidSearchName"&gt;cn&lt;/property&gt;
     
     &lt;property name="java.naming.security.principal"&gt;CN=xxx,dc=xxxxxxxx,dc=internal&lt;/property&gt;
     &lt;property name="java.naming.security.credentials"&gt;xxxxx&lt;/property&gt;
     
     &lt;property name="exclusive-access"&gt;true&lt;/property&gt;
    &lt;/provider&gt;

    &lt;provider class="com.atlassian.jira.user.osuser.JiraOFBizCredentialsProvider"&gt;
        &lt;property name="exclusive-access"&gt;true&lt;/property&gt;
    &lt;/provider&gt;
 
    &lt;provider class="com.atlassian.jira.user.osuser.JiraOFBizProfileProvider"&gt;
        &lt;property name="exclusive-access"&gt;true&lt;/property&gt;
    &lt;/provider&gt;
 
    &lt;provider class="com.atlassian.jira.user.osuser.JiraOFBizAccessProvider"&gt;
        &lt;property name="exclusive-access"&gt;true&lt;/property&gt;
    &lt;/provider&gt;
&lt;/opensymphony-user&gt;

I hope this has helped.

Cheers

Yes, you're right - I had too many settings. I was still using the settings of a custom provider we have for 4.1.2, which is not supported in 4.4.5. Thanks!

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Julia Dillon
Posted Tuesday in Jira

Tell us how your team runs on Jira!

Hey Atlassian Community! Today we are launching a bunch of customer stories about the amazing work teams, like Dropbox and Twilio, are doing with Jira. You can check out the stories here. The thi...

145 views 1 17
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you