Unauthorized Access - Please login to remote application

I have 2 jira instances to each other via application link.

When i try to access that application link in Configuration Manager addon it throws below error message in both the instances.

I have added respecitve IPs to both instances as trusted application for incoming and outgoing authentication

"Unauthorized Access

You have to authorise this operation first. Please login into the remote application."

9 answers

Do I have to login with local admin?

warning in atlassian-jira.log

SimpleHttpConnectionManager being used incorrectly. Be sure that HttpMethod.releaseConnection() is always called and that only one thread and/or method is using this connection manager at a time.

0 votes

Are you using the same user between the instances? If not, you should use oAuth method instead of trusted.

Yes, I'm using same user. It is active directory user which is admin on the both jira.

Still I need to use oAth authentication?

When I looked into Configurare screen, it shows oAuth is also enabled.

I'm using trusted application.

Is it by defaul that oAuth is enabled. Do i need to disable it?

0 votes

If the user base is the same we can stick with trusted. Please note that we can only have one authenticator, so oAuth needs to be disabled. In case it doesn't work, I suggest to disable trusted and try to use oAuth.

0 votes

One more thing, leave the ip patterns and url pattenrs in blank, you can setup this later once you make the applications talking to each other. :)

Do i need to use local jira user?

Did not work :(

I disabled oauth and removed ip pattern from trusted applicaiton

also disabled trusted application and enabled oauth

- same error

0 votes

Instead of using the Configuration Manager addon , can you login in JIRA as administrator and follow the documentation below?

https://confluence.atlassian.com/display/JIRA/Linking+to+Another+Application

I don't have same local users on both jira.
Do i need those?
0 votes

On this case the user base is not the same, we should use oAuth which will use a token to authenticate instead the username.

I have tried oauth as well however that did not work

I just enabled it and same error.

Currently I have delete the links. When I do it again, shall I select checkbox where it asks - Are you admin on both jira (something like this, this msg comes after "are users same on both instance")

@Luciano Fagundes, have you ever gotten this resolved? I have the same problem...

Hey this is the solution you are looking for: https://kb.botronsoft.com/display/PS/Unauthorized+Access+message+when+browsing+snapshots+from+a+Linked+Jira+Instance

Just make sure you click on the 'Authenticate' link. Enjoy!

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Sep 25, 2018 in Jira

Atlassian Research Workshop opportunity on Sep. 28th in Austin, TX

We're looking for participants for a workshop at Atlassian! We need Jira admins who have interesting custom workflows, issue views, or boards. Think you have a story to sha...

439 views 7 5
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you