Unable clone issues after upgrade of jira 6.4 to 7.

2016-01-05 14:33:25,150 http-nio-8080-exec-12 ERROR      [o.a.c.c.C.[.[localhost].[/].[action]] Servlet.service() for servlet [action] in context with path [] threw exception [Servlet execution threw an exception] with root cause
java.lang.NoSuchMethodError: com.atlassian.jira.security.groups.GroupManager.isUserInGroup(Lcom/atlassian/crowd/embedded/api/User;Lcom/atlassian/crowd/embedded/api/Group;)Z
        at com.go2group.jira.plugins.sl.customfield.LastNonG2GUserCF.getValueFromIssue(LastNonG2GUserCF.java:63)
        at com.go2group.jira.plugins.sl.customfield.LastNonG2GUserCF.getValueFromIssue(LastNonG2GUserCF.java:25)
        at com.atlassian.jira.issue.fields.CustomFieldImpl.getValue(CustomFieldImpl.java:418)
        at com.atlassian.jira.web.action.issue.CloneIssueDetails.cloneSomeFieldsFromOriginalIssue(CloneIssueDetails.java:246)
        at com.atlassian.jira.web.action.issue.CloneIssueDetails.prepareForCloningIssue(CloneIssueDetails.java:203)
        at com.atlassian.jira.web.action.issue.CloneIssueDetails.doExecute(CloneIssueDetails.java:272)
        ... 1 filtered
        at com.atlassian.jira.action.JiraActionSupport.execute(JiraActionSupport.java:67)
        ... 7 filtered
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:725)
        ... 55 filtered
        at com.atlassian.greenhopper.jira.filters.ClassicBoardRouter.doFilter(ClassicBoardRouter.java:59)
        ... 147 filtered
        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
        at org.apache.tomcat.util.threads.TaskThread$WrappingRunnable.run(TaskThread.java:61)
        at java.lang.Thread.run(Thread.java:745)

2 answers

0 vote

Your Go2Group customfield add-on is broken for that version of JIRA.  Check that there is a valid version in admin -> manage versions and upgrade to a working one.  If it's not valid for your version, you might be a bit stuck and you'll need to delete the field to get it to work.

 

Thanks for the very prompt response.

I have disabled the go2group customfield add-on, but still I am facing the same issue and getting the same error.

Kindly help to resolve the issue.

You need to delete the field then. Is there no upgrade available for the add-on?

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Julia Dillon
Posted Tuesday in Jira

Tell us how your team runs on Jira!

Hey Atlassian Community! Today we are launching a bunch of customer stories about the amazing work teams, like Dropbox and Twilio, are doing with Jira. You can check out the stories here. The thi...

211 views 1 18
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you