Select List - None

How do I get rid of "None" as a value in a Radio Button, Checkbox, or Select List custom field.

Whenever I create any of these custom fields, "None" is there by default and I would like for it to go away.

4 answers

1 accepted

This widget could not be displayed.

you make field mandatory on field configuration then "None" option will disapper.

another way is you can modify velocity files for this check the following document

https://confluence.atlassian.com/display/JIRAKB/How+to+Remove+'NONE'+from+a+Select+List+Custom+Field

another way is using Javascript(let me know if you want do this way)

I have the same problem in my JIRA 5.1 instance. I changed one of my select fields to Required in the field configuration. Now it will not let me select None, which is an improvement, but it still shows None as an option, which is a problem still. Is that expected when making the field required?

Note that editing the velocity files removes None from ALL the Select lists in your instance of JIRA, according to the documentation @rambanam posted a link to.

Yes, it will remove "None" option globally if velocity templetes edited.

as i said by making field required on field configuration it will hide none apart from this we need to set default value for that field

I wish that were the case @rambanam. From what I have seen, it doesn't hide the None option - it just stops allowing users to choose it. @Jobin also says the same thing below.

This widget could not be displayed.

There is also a non-hacky way where the field is made mandatory. That will not take away the "None" option but you will be forced to select another one (unless you gave another value as default).

If you must get rid of None, follow Rambanam's advise.

You answered my question about None still showing when the field is Required before I even asked it! Thanks @Jobin.

This widget could not be displayed.

Rambanam Prasad, you mentioned that there's a way to do this using Javascript - could you describe how to do it that way?

This widget could not be displayed.

You have to make the field required, then the 'none' won't be there anymore.

Not true... I have done this and it still shows up.  I am on JIRA 7.4

Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Posted Wednesday in New to Jira

Are you planning to trial, or are currently trialling Jira Software? - We want to talk to you!

Hello! I'm Rayen, a product manager at Atlassian. My team and I are working hard to improve the trial experience for Jira Software Cloud. We are interested in   talking to 20 people planning t...

255 views 5 0
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you