Scriptrunner Rest EndPoint : Issue Running

Hello All

 

I have created ScriptRunner REST endpoint to create issues. It works perfectly in my local Jira instance. When I deploy in production Jira and call it using like this: from SOAPUI 

http://mycompany:8080/rest/scriptrunner/latest/custom/restCreateIssue?projectname=MPJ&issuetype=bug&reporterid=admin&summary=mysteingdescr&description=mydescription1

It shows me profile page as response, instead of creating issue.

I have authorization headers set as I have done it in my local, not sure how to debug it..?

Any idea?

 

Please let me know.

Thanks

Kumar

 

1 answer

0 vote
Alexey Matveev Community Champion Nov 16, 2017

Hello,

Your user does not have permissions to create an issue in the production environment? Your user have a different password in production? You did not set rest call as POST in Soap UI? You entered wrong URL?

Ok it really beats me...

It works now and I did not change a thing ..????

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Julia Dillon
Posted Tuesday in Jira

Tell us how your team runs on Jira!

Hey Atlassian Community! Today we are launching a bunch of customer stories about the amazing work teams, like Dropbox and Twilio, are doing with Jira. You can check out the stories here. The thi...

475 views 1 18
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you