SSL LDAP for Jira - SSLPoke

Eliane Champagne January 27, 2020

Hello wonderful community,

I have went through every post made on Atlassian and even Google on a way to connect Jira to AD with LDAP over SSL.

I tried to use the SSLPoke class, but it seems the module is not registered. I'm a sysadmin, and not a programmer by any means! I never used Java apart from those solutions. So I cannot use it to see if server is accepting connections. However, TCP port 636 is opened and listening on that LDAP server. It's also opened on Windows Firewall.

I added certs on CACERTS store. Website is working awesome over SSL, but I cannot make it authenticate over LDAPS.

Can you give me any tips on how to make SSLPoke class work? I've never found any documentation with the "sslpoke" file, on how to be able to use it!

D:\Atlassian\Confluence\jre\bin>java sslpoke "LDAPServerFQDN" 636
Error: Could not find or load main class sslpoke 

3 answers

1 accepted

0 votes
Answer accepted
Eliane Champagne January 29, 2020

OK, I founded it! It works for both Jira and Confluence.

First, about SSLPoke.class

I had another JRE instance on my server, which was causing another JAVA.EXE to be executed when I typed "java SSLPoke *FQDN* 636". Once I specified the complete path to which java executable I wanted to use, then everything worked as designed.

Second, I was missing my CA Authenticating certificate in my CACERTS store. I had servers key pairs, but I was missing that one. Once that certificate was generated again and included in CACERTS keystore, LDAPS worked like a charm!

Documentation used :

0 votes
Hua Soon SIM _Akeles_
Marketplace Partner
Marketplace Partners provide apps and integrations available on the Atlassian Marketplace that extend the power of Atlassian products.
April 3, 2024

For those who encountered the error message 

Error: Could not find or load main class SSLPoke

Another possible reason is the SSLPoke.class is not copied to the same directory with java.

The solution will be to include the current directory in the classpath.

It will be something like this

$JAVA_HOME/bin/java -cp . SSLPoke <FQDN> <Port>
$JAVA_HOME/bin/java -cp . SSLPoke *FQDN* 636
0 votes
Adrian Stephen
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
January 27, 2020

Hi @Eliane Champagne 

Welcome to the Atlassian Community & nice to have you here! 

You are seeing this error message because the SSLPoke is not downloaded into the directory that you are executing the command on. 

You may download the SSLPoke file from this article:

Here is the directly download link :

If you are running the command from the D:\Atlassian\Confluence\jre\bin directory, move this file there. Then execute the command again. 

Please keep us updated on how it went & hope to hear from you soon.

Have a nice day. 

Adrian Stephen

Eliane Champagne January 27, 2020

Hello Mr. Stephen,

Thank you for that reply!

This is exactly where I've added SSLPoke file. Here is a screen capture from CMD prompt and files.


This is why I'm not sure why it is not working...




Eliane Champagne January 27, 2020

Sorry, wrong edit in the screenshot!


Command ran was : java sslpoke "*LDAP SERVER FQDN*" 636

Suggest an answer

Log in or Sign up to answer