Problem upgrading from jira 4.1 to 4.4.5

Hello,

I created a new install of JIRA 4.4.5 and backed-up the db to the xml file.

JIRA 4.4.5 starts ok pointing to new empty db.

I made sure my osuser.xml file was in the new JIRA folder before the restore of the xml.

Stil lafter the upgrade i get "JIRA is unable to migrate the User Directory configuration because the osuser.xml file does not contain a recognised configuration."

Already looked at JRA-24161 and JRA-29071 cases and still not working.

 

Here's my osuser.xml

<opensymphony-user>

    <authenticator class="com.opensymphony.user.authenticator.SmartAuthenticator" />

<provider class="com.opensymphony.user.provider.ldap.LDAPCredentialsProvider">
        <property name="java.naming.factory.initial">com.sun.jndi.ldap.LdapCtxFactory</property>
        <property name="java.naming.provider.url">ldap://x.x.x.x:389</property>
        <property name="searchBase">DC=mydc,DC=local</property>
        <property name="uidSearchName">sAMAccountName</property>

     <property name="java.naming.security.principal">cn=admin,cn=users,dc=mydc,dc=local</property>
     <property name="java.naming.security.credentials">Password</property>

        <property name="exclusive-access">true</property>
    </provider>
<provider class="com.atlassian.jira.user.osuser.JiraOFBizCredentialsProvider">
        <property name="exclusive-access">true</property>
    </provider>

    <provider class="com.atlassian.jira.user.osuser.JiraOFBizProfileProvider">
        <property name="exclusive-access">true</property>
    </provider>

    <provider class="com.atlassian.jira.user.osuser.JiraOFBizAccessProvider">
        <property name="exclusive-access">true</property>
    </provider>
    
    <provider class="com.atlassian.core.ofbiz.osuser.CoreOFBizCredentialsProvider">
        <property name="exclusive-access">true</property>
    </provider>

    <provider class="com.atlassian.jira.user.osuser.JiraOFBizProfileProvider">
        <property name="exclusive-access">true</property>
    </provider>

    <provider class="com.atlassian.jira.user.osuser.JiraOFBizAccessProvider">
        <property name="exclusive-access">true</property>
    </provider>
</opensymphony-user>

Any help will greatly be appreciated, i have to upgrade to 6.4.2 and need it to work in 4.4.5 first according to docs.

1 answer

This widget could not be displayed.

Have you gone through the upgrade guide for all intermediate versions?

JIRA underwent major changes regarding user directories in 4.3 and i am assuming you may be affected by that. 

Go through this link again and doublecheck if you have performed all steps in here

https://confluence.atlassian.com/display/JIRA/JIRA+4.3+Upgrade+Guide

Rahul

Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Posted Wednesday in New to Jira

Are you planning to trial, or are currently trialling Jira Software? - We want to talk to you!

Hello! I'm Rayen, a product manager at Atlassian. My team and I are working hard to improve the trial experience for Jira Software Cloud. We are interested in   talking to 20 people planning t...

85 views 1 0
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you