NOT IN searches taking ages on JIRA


I am on jira 5.0.

I did a full re-index of database this morning.

After that when i do searches it is all fine, however the moment i perform searches with clause project NOT IN("aaa","bbb"), the search takes minutes and still doesn ot return any results

What could be causing this issue?

How can i fix this?


2 answers

1 accepted

1 vote
Accepted answer
Tarun Sapra Community Champion Mar 31, 2014

Can you try deleting indexes folder and then doing a re-indexing again instead of just re-indexing without first deleting.

Yes reindex with deleting folder resolved the issue.

It seams like "Project not in" should return many issues - maybe it is out of memory issue.... Is there any errors in LOGs?

No errors and it was supposed to return 100 records. Any ideas why it may be taking long?

Have you tried another reindexing? Maybe reindex failed... Is database ok?

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Jan 08, 2019 in Jira

How to Jira for designers

I’m a designer on the Jira team. For a long time, I’ve fielded questions from other designers about how they should be using Jira Software with their design team. I’ve also heard feedback from other ...

1,279 views 5 10
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you