Load more than 10 comments at once

Ray
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
August 5, 2022

image.png

After upgrading to Jira version 9.1.0 we have to click "Load 10 newer comments" for each ticket with tens of comments. We would like to remove this feature or set the limit to a higher value. Sadly, after searching online we didn't find a way to do this. Maybe anyone knows how to do it?

We also thought, that the Advanced Setting jira.comment.collapsing.minimum.hidden would change this limit, but apparently not.

2 answers

1 accepted

0 votes
Answer accepted
Trudy Claspill
Community Leader
Community Leader
Community Leaders are connectors, ambassadors, and mentors. On the online community, they serve as thought leaders, product experts, and moderators.
August 5, 2022

Hello @Ray 

Welcome to the community.

Per the v9.x release notes this was an intentional change to mitigate this issue:

https://jira.atlassian.com/browse/JRASERVER-60107

It doesn't seem that Atlassian has provided a method to override that 10 is the default to load. This change request might be related to that.

https://jira.atlassian.com/browse/JRASERVER-72359

Ray
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
August 8, 2022

Thank you for your reply. Hoping that this feature will get added soon.

Like Marco Schrieck likes this
Mr Andersen September 14, 2022

I hope this feature will be added soon too. It's one of the main complaints of my users, after upgrading to 9.20 from version 8.

The previous solution with hiding oldest comments instead, was much less intrusive.

Like # people like this
ChristianWaidner October 27, 2022

Intentionally changing is ok - but please consider the consequences:

I have reversed the sorting to "oldest first", because this is the more intuitive behaviour and the button to add new comments is at the end.

Result: The newest comments are not shown, if the issue has more than 10 comments. This makes totally no sense to me. Please fix ASAP.

Like # people like this
Kimmo Lindholm
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
November 14, 2022

We are now on day 1 after upgrading to 9+ and this is propably the most annoying "improvement" there is.
Maybe time for some grease monkey scripting - again.

Like Mark Phillips likes this
Datema DEV
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
December 9, 2022

I could live with the default being dispaying only 10 comments when sorted newest first.
But then I like to have to add new comments above the most recent comment instead of scrollig all the way down and adding my new comment below the oldest comment theat is displayed ... 
Please consider to implement that as an improvement.
BTW: I like Jira a lot ! Thanks for this great product.

Like # people like this
Trudy Claspill
Community Leader
Community Leader
Community Leaders are connectors, ambassadors, and mentors. On the online community, they serve as thought leaders, product experts, and moderators.
December 9, 2022

For anybody commenting on this post, remember that this is a user community and not the best way to get your feedback directly to Atlassian. Go to the referenced issue(s) and add your votes/comments there.

ValdasVa
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
January 2, 2023
0 votes
Babu R March 7, 2023

Bug Reported at https://jira.atlassian.com/browse/JRASERVER-74440

jira.comment.collapsing.minimum.hidden is no longer working on 9.x

 

Steps to Reproduce

  1. Navigate to Administration >> System >> General Configuration >> Advanced Settings and modify the jira.comment.collapsing.minimum.hidden to 0
    • PS: This should disable the comment collapsing.
  2. Open a issue with at least 11 comments, you should see all 11 comments on screen, but instead, you see 10 comments and the rest is collapsed.
  3. If you change jira.comment.collapsing.minimum.hidden to 4, or any number, you still see the same behavior.

Expected Results

When you have jira.comment.collapsing.minimum.hidden=4 (default value), the result should be:

    • The first 8 comments will show without collapsing;
    • When the 9th comment is added, Jira shows 5 comments on screen and 4 are collapsed;

When you have jira.comment.collapsing.minimum.hidden=0, the result should be:

    • All comments will show on screen, no collapsing.

Suggest an answer

Log in or Sign up to answer