Jira was locked

I moved the evaluation 5.1.1 version of Jira to the 2012 Windows server from the original machine and started Jira as application - it failed. I looked at the atlassian-jira.log and found the record below:

2012-10-31 21:16:20,875 main FATAL atlassian.jira.startup.JiraStartupLogger Startup check failed. JIRA will be locked.

The search did not find no *lock* file under Jira home directory.

I tried to start Jira on the original system – same result.

Goal

1. Move Jira onto 2012 Windows server and keep its configuration.

2. Export Jira’s data from default db to SQL Server 2012.

Excerpt from the log

========================

2012-10-31 21:16:20,609 main INFO atlassian.jira.startup.JiraStartupLogger

****************

JIRA starting...

****************

2012-10-31 21:16:20,750 main INFO atlassian.jira.startup.JiraStartupLogger

___ Environment _____________________________

JIRA Build : 5.1.1#772-sha1:c73db67d5b7b5c0c6559cdfee76905e8ca1a63cb

Build Date : Tue Jul 17 00:00:00 EDT 2012

JIRA Installation Type : Standalone

Application Server : Apache Tomcat/6.0.32 - Servlet API 2.5

Java Version : 1.6.0_33 - Sun Microsystems Inc.

Current Working Directory : C: Atlassian jira-5.1.1 bin

Maximum Allowable Memory : 742MB

Total Memory : 247MB

Free Memory : 188MB

Used Memory : 59MB

Memory Pool: Code Cache : Code Cache: init = 163840(160K) used = 1524800(1489K) committed = 1540096(1504K) max = 33554432(32768K)

Memory Pool: Eden Space : Eden Space: init = 71630848(69952K) used = 61737080(60290K) committed = 71630848(69952K) max = 214827008(209792K)

Memory Pool: Survivor Space : Survivor Space: init = 8912896(8704K) used = 0(0K) committed = 8912896(8704K) max = 26804224(26176K)

Memory Pool: Tenured Gen : Tenured Gen: init = 178978816(174784K) used = 0(0K) committed = 178978816(174784K) max = 536870912(524288K)

Memory Pool: Perm Gen : Perm Gen: init = 12582912(12288K) used = 10739928(10488K) committed = 12582912(12288K) max = 268435456(262144K)

JVM Input Arguments : -XX:MaxPermSize=256m -Xms256m -Xmx768m -Djava.awt.headless=true -Datlassian.standalone=JIRA -Dorg.apache.jasper.runtime.BodyContentImpl.LIMIT_BUFFER=true -Dmail.mime.decodeparameters=true -XX:+PrintGCDateStamps -Djava.util.logging.config.file=C: Atlassian jira-5.1.1 conf logging.properties -Djava.util.logging.manager=org.apache.juli.ClassLoaderLogManager -Djava.endorsed.dirs=C: Atlassian jira-5.1.1 endorsed -Dcatalina.base=C: Atlassian jira-5.1.1 -Dcatalina.home=C: Atlassian jira-5.1.1 -Djava.io.tmpdir=C: Atlassian jira-5.1.1 temp

___ Java System Properties ________________

atlassian.standalone : JIRA

awt.toolkit : sun.awt.windows.WToolkit

catalina.base : C: Atlassian jira-5.1.1

catalina.home : C: Atlassian jira-5.1.1

catalina.useNaming : true

common.loader : ${catalina.base}/lib,

${catalina.base}/lib/*.jar,

${catalina.home}/lib,

${catalina.home}/lib/*.jar

file.encoding : Cp1252

file.encoding.pkg : sun.io

java.awt.graphicsenv : sun.awt.Win32GraphicsEnvironment

java.awt.headless : true

java.awt.printerjob : sun.awt.windows.WPrinterJob

java.class.version : 50.0

java.home : C: Atlassian jdk1.6.0_33 jre

java.io.tmpdir : C: Atlassian jira-5.1.1 temp

java.naming.factory.initial : org.apache.naming.java.javaURLContextFactory

java.naming.factory.url.pkgs : org.apache.naming

java.runtime.name : Java(TM) SE Runtime Environment

java.runtime.version : 1.6.0_33-b03

java.specification.name : Java Platform API Specification

java.specification.vendor : Sun Microsystems Inc.

java.specification.version : 1.6

java.util.logging.config.file : C: Atlassian jira-5.1.1 conf logging.properties

java.util.logging.manager : org.apache.juli.ClassLoaderLogManager

java.vendor : Sun Microsystems Inc.

java.vendor.url : http://java.sun.com/

java.vendor.url.bug : http://java.sun.com/cgi-bin/bugreport.cgi

java.version : 1.6.0_33

java.vm.info : mixed mode

java.vm.name : Java HotSpot(TM) Client VM

java.vm.specification.name : Java Virtual Machine Specification

java.vm.specification.vendor : Sun Microsystems Inc.

java.vm.specification.version : 1.0

java.vm.vendor : Sun Microsystems Inc.

java.vm.version : 20.8-b03

mail.mime.decodeparameters : true

org.apache.jasper.runtime.BodyContentImpl.LIMIT_BUFFER : true

os.arch : x86

os.name : Windows NT (unknown)

os.version : 6.2

package.access : sun.,

org.apache.catalina.,

org.apache.coyote.,

org.apache.tomcat.,

org.apache.jasper.,

sun.beans.

package.definition : sun.,

java.,

org.apache.catalina.,

org.apache.coyote.,

org.apache.tomcat.,

org.apache.jasper.

server.loader :

shared.loader :

sun.arch.data.model : 32

sun.boot.library.path : C: Atlassian jdk1.6.0_33 jre bin

sun.cpu.endian : little

sun.cpu.isalist : pentium_pro+mmx pentium_pro pentium+mmx pentium i486 i386 i86

sun.desktop : windows

sun.io.unicode.encoding : UnicodeLittle

sun.java.command : org.apache.catalina.startup.Bootstrap start

sun.java.launcher : SUN_STANDARD

sun.jnu.encoding : Cp1252

sun.management.compiler : HotSpot Client Compiler

sun.os.patch.level :

tomcat.util.buf.StringCache.byte.enabled : true

user.country : US

user.dir : C: Atlassian jira-5.1.1 bin

user.home : C: Users Administrator

user.language : en

user.name : Administrator

user.timezone : America/New_York

user.variant :

2012-10-31 21:16:20,797 main INFO atlassian.jira.startup.JiraStartupLogger Running JIRA startup checks.

2012-10-31 21:16:20,859 main FATAL atlassian.jira.startup.JiraStartupLogger

***********************************************************************************************************************************************

No jira.home is configured.

See https://docs.atlassian.com/jira/docs-051/Setting+your+JIRA+Home+Directory for instructions on setting jira.home

***********************************************************************************************************************************************

2012-10-31 21:16:20,875 main FATAL atlassian.jira.startup.JiraStartupLogger Startup check failed. JIRA will be locked.

2012-10-31 21:16:21,687 main ERROR jira.web.dispatcher.JiraWebworkActionDispatcher

******************************************

JIRA startup failed, JIRA has been locked.

******************************************

2 answers

1 accepted

Accepted Answer
0 votes

It's telling you exactly what the problem is at the bottom of that log - you have not configured it correctly.

I suspect you've tried to copy/move the application directory on to the new server. You can make that work, but frankly, don't bother, because it's a heck of a lot of mostly pointless, dull and error-prone slog work. You should really install a new system from scratch, get it working (with an empty database) and then point it at the old database.

0 votes

As Nic said, the problem is that you've not configured the JIRA HOME Directory. To configure it, you'll simply need to use the Configuration Tool inside your JIRA_Install/bin folder (see Configuring the JIRA Home Directory).

However, if you are planning on moving JIRA from one server to the other, I'd advise you to follow the Migrating JIRA to Another Server documentation rather then simply copying the folders from one server to the other.

Yup, I've seen flat server to server copies a few times. Never seen one work well, except when the servers were identical in terms of software (identical OS, disks, directory structure, versions of software - only the hardware changed). I wouldn't even think of a simple copy across Windows versions - always install clean on that, because it's a dreadfully designed OS that makes dumb, undocumented and unpredictable changes.

Thank you for the notes. I did exactly as Nick said, installed a new app, tested startup and replaced the default db with mine. And it worked.

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Sep 18, 2018 in Jira

What modern development practices are at the heart of how your team delivers software?

Hey Community mates! Claire here from the Software Product Marketing team. We all know software development changes rapidly, and it's often tough to keep up. But from our research, we've found the h...

26,071 views 2 7
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you