Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,456,296
Community Members
 
Community Events
176
Community Groups

Jira unattended install hangs "for ever"

We are in the proces of scripting Jira upgrade using the unattended installation functionality via Powershell, as the installation requires a number of minor modifications/customizations.

We have the automatic upgrade working when running the script by hand, but when running it in a Powershell as part of an Azure DevOps pipeline - run by an Azure DevOps agent hosted on the Jira server itself - the unattended installer simply hangs.

We've tried monitoring it with 'procmon', both when run manually and via pipeline, and the difference is marked. During the manual run files/service/registry entries are removed/added, while if we start it via a pipeline the process is started, but nothing is done - no files/registry entries/services are changed.

We've tried to run the installer from command line, as part of the pipeline, in order to reduce the issue to the minimum. Same issue.

Any ideas?

br

Peter

1 answer

Hi Peter,

Does the user you run the installation with (via pipeline or commandline) have sufficient permissions to make the changes you mentioned?

And is the installed doing anything at all? Or does it hang from the start?

Hi Charlie,

For the commandline installation we ran with a personal account with local administrator. For the installation via pipeline we've having the Azure DevOps agents service run as both a service account (having local admin) as well as having the agent service running as the same personal user who could run the installation successfully from the commandline.

We did a bit more digging today, and via processmonitor we found reference to a logfile placed in C:\Users\USERNAME\AppData\Local\Temp, which showed the following at the end of it
[5:195] Creating JVM
[5:271] JVM created
[5:272] load helper dll
[5:274] helper dll (in-module) 00007FF793620000
[5:314] setting exe4j.moduleName to E:\T\a1\w\6\s\jira-8.20.14-x64.exe
[5:315] main class: com/install4j/runtime/launcher/WinLauncher
[5:318] param count: 9
[5:320] param 0: false
[5:321] param 1: com.install4j.runtime.installer.Installer
[5:322] param 2: E:\T\a1\w\6\s\error.log
[5:323] param 3:
[5:325] param 4: false
[5:326] param 5: E:\T\a1\w\6\s\jira-8.20.14-x64.exe
[5:327] param 6: -q
[5:328] param 7: -varfile
[5:330] param 8: ./jira\\response.varfile
[5:331] calling main

Indicating that a Java was started. We found a Java which ran for a few seconds but couldn't see that it actually did anything.

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
SERVER
VERSION
8.20.11
TAGS

Atlassian Community Events