Jira automation not working for a user

We've had jira automation working as one of our users. Now we've created a dedicated automatic response user and set it as admin for the project.

The automation plugin gives an error on running a transition "You do not have permission to assign issues."

When I login as that user and click the button for the transition, it works fine.

How can I get this working?

3 answers

I've run into the same problem. Haven't identified the cause. If you have, I would love to know. 

Same issue here. Log shows "You do not have permission to assign issues".

Created a user "Automation Bot", with all possible permissions within our JIRA instance. In my particular case it concerns a project for which service desk is enabled. The bot is also member of the service desk team. 

If I change the acting user, eg. to myself, there is no such error. 

The actor field is case-sensitive. In our case "Automation Bot" needed to be renamed to "automation bot". 

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Tuesday in Jira

Looking for anyone who made the switch to Data Center

The Jira Marketing team is putting together an ebook on migrating to Data Center. We're looking for pro tips on how you staffed your project team and organized your Proof of Concept. Share yo...

36 views 0 2
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you