Jira automation not working for a user

We've had jira automation working as one of our users. Now we've created a dedicated automatic response user and set it as admin for the project.

The automation plugin gives an error on running a transition "You do not have permission to assign issues."

When I login as that user and click the button for the transition, it works fine.

How can I get this working?

3 answers

I've run into the same problem. Haven't identified the cause. If you have, I would love to know. 

Same issue here. Log shows "You do not have permission to assign issues".

Created a user "Automation Bot", with all possible permissions within our JIRA instance. In my particular case it concerns a project for which service desk is enabled. The bot is also member of the service desk team. 

If I change the acting user, eg. to myself, there is no such error. 

The actor field is case-sensitive. In our case "Automation Bot" needed to be renamed to "automation bot". 

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Julia Dillon
Posted Tuesday in Jira

Tell us how your team runs on Jira!

Hey Atlassian Community! Today we are launching a bunch of customer stories about the amazing work teams, like Dropbox and Twilio, are doing with Jira. You can check out the stories here. The thi...

233 views 1 18
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you