Issue level security - unsuccessful

Hi,

I have my requirement like this:

User can create an issue and there will be a multi-group field "MyGroups" to be populated while creating. Only the populated groups can access the issue.

Here are my steps to achieve this:

1. Created "issue security scheme" with a single security level "test" by adding this multi-group customfield(MyGroups).

2. Added this security scheme to "MyProject" and enabled "set Issue security" for jira-users in this project permissions.

When I create an issue by adding a group(jira-administrators) into MyGroups, still the issue is accessible outside users of the given group(jira-administrators).

Am I missing anything here in my configuration?

Please help me. Thanks in advance!

6 answers

1 accepted

This widget could not be displayed.

From what I read I would say there is no security level set on the issue.

When you create the issue, do you set the security level for this issue to "test" by default?

Do you have the permission to set the security level?

This widget could not be displayed.

As @Udo said you have to set Security Level dropdown field value as test

check this doc for more information

https://confluence.atlassian.com/display/JIRA/Setting+Security+on+an+Issue

https://confluence.atlassian.com/display/JIRA/Configuring+Issue-level+Security

This widget could not be displayed.

Maybe you are looking to do the step than Rambanam says automagically - if so consider using https://jamieechlin.atlassian.net/wiki/display/GRV/Built-In+Scripts#Built-InScripts-SetIssueSecurity.

This widget could not be displayed.

Setting "test" security level as default solves my problem. Thanks!

This widget could not be displayed.

I have only one security level and it should be applied to all the issues. So I don't want user(who has perms) to modify the security level manually. I tried hiding "security level" field in my field configuration scheme then it is not working as expected. As I set test as my default security level, the issue should have value test in security level field though it is not show on create/edit issue right? am I missing anything here?

This widget could not be displayed.

https://jira.atlassian.com/browse/JRA-12125 solved my problem. Thanks!

Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Posted Wednesday in New to Jira

Are you planning to trial, or are currently trialling Jira Software? - We want to talk to you!

Hello! I'm Rayen, a product manager at Atlassian. My team and I are working hard to improve the trial experience for Jira Software Cloud. We are interested in   talking to 20 people planning t...

97 views 1 0
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you