How do I set the right permissions so Automation app user can do its stuff?

Vinicius Correia May 6, 2020

Hello there,

I have created a bunch of JIRA automation rules but they are not working. It seems the actor responsible for executing the rules does not have project permissions to do it.

Or at least is what I understood from this information displayed by JIRA:
Screenshot_1.png

5 answers

1 accepted

6 votes
Answer accepted
Petter Gonçalves
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
May 7, 2020

Hello @Vinicius Correia

Thank you for reaching out.

The actor of your automation rule (Automation app user) is added by default to the role "atlassian-addons-project-access".

That being said, I suggest checking the following steps:

  1. Navigate to the Project > Project settings > Permissions > check if the "atlassian-addons-project-access" is added to your project permission, especially in the "Edit issues" permission.
  2. If that didn't work, please provide us the audit log errors returned when you tried to trigger the rule

Let us know if you have any questions.

BetterLife June 4, 2020

Hello @Petter Gonçalves 

I am experiencing a similar issue when trying set issue security level from Project Automation.  I have checked and the atlassian-addons-project-access role does have the Set Issue Security and Edit Issue permissions.

Also, I am successfully setting the assignee from the same automation rule. The attempt at setting issue security level is a second action on the same rule, but that fails.

Capture.PNGAny advice?

BetterLife June 4, 2020

Ok, I think I've solved my own problem. 

The atlassian-addons-project-access role was not configured to be a member of the security level(s) that it was trying to set.  Making this role a member of every security level in the scheme seems to have solved my problem.

It would seem that a user cannot set the security level of an issue to a level that excludes themselves.  This may be obvious in hindsight, but it was not obvious to me. Live and learn.

@Petter Gonçalves your post pointed me to the atlassian-addons-project-access which gave me a starting point to work from.  So, thank you!

Like # people like this
Romel July 16, 2020

@Petter Gonçalves How to solve a similar issue with Next-gen project while running my automation rules. I am getting the following error:

"Actor does not have permission to view one or more issues, or the issue was deleted (please check permissions and issue security levels)".

Actor in case is "Automation app user"

Any help is highly appreciated.  

P.S.: The automation rules were running fine before we created custom roles. Not sure if that's causing the issue, but I'm not able to tie them together.

John Funk
Community Leader
Community Leader
Community Leaders are connectors, ambassadors, and mentors. On the online community, they serve as thought leaders, product experts, and moderators.
July 16, 2020

Hi Romel,

First, it is better to create a new question for each new situation. 

But for now, please check the permissions in the Permission scheme to make sure that the atlassian-addons group pretty much has all of the permissions. 

Romel July 16, 2020

@John Funk , I asked the question here in the same thread as it pertained to a similar issue but with a different project type, but nonetheless I'll make sure the next time.

BTW does next-gen projects have a permission scheme?, all I Know is a user can be given access via the access menu.

John Funk
Community Leader
Community Leader
Community Leaders are connectors, ambassadors, and mentors. On the online community, they serve as thought leaders, product experts, and moderators.
July 16, 2020

I forgot it was a Next-gen project - thanks for that reminder. No, those project types don't have a permission scheme. I would back out your new custom roles one by one until it works again to see what was the culprit. 

Like # people like this
Andrew Tyler January 14, 2021

Hello, @Petter Gonçalves  and @John Funk 

I am having the same issue as @Vinicius Correia and I have checked that atlassian-addons-project-access does have Edit Issues permission for the project, so would appreciate assistance with trying to resolve the problem, please?
(I notice that @Vinicius Correia has not replied to say whether it resolved her problem?)

The Automation Audit Log for my rule (which is one from the library, rather than one that I have created) is below:

Automation Rule Error.PNGThank you.
Regards, Andrew Tyler

Ivan Shamrikov May 20, 2022

Check the issue security and give access to User "Automation for Jira"

1 vote
정진용
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
June 29, 2022

Hi!  I solved this problem.

permissions -> adminster projects, Browse projects -> Single user(Automation for Jira) Add

Good Luck!

1 vote
Andrea Mazzeschi October 26, 2020

Hi everyone,

I'm trying to create a rule that assign a particular level of security based on the issue type.

 

I checked that:

- the atlassian-addons-project-access role is configured to be a member of the security level I'm trying to set, as suggested by @BetterLife 

- the atlassian-addons-project-access role has all the permissions in my project.

 

Attached is the log I get when I create the issue an the automatation runs.

 

Do you have any suggests? What am I missing?

tmp.PNG

Dana Gould September 28, 2021

Did you ever find a solve for this? I am running into the same issue and have done similar troubleshooting steps as you up to this point. Would love to hear how you or others moved on from here.

Like BOIKO Artem (龙辉) likes this
BOIKO Artem (龙辉)
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
May 23, 2024

Hello! I've just finished long troubleshooting of that type of issue. So what you need to check - is that you have this small lock of security level for your issue type, even if all automation is switched off:1.png

If you don't see it, you will have "We couldn't set a new security level for this issue. Check the rule actor's permissions and try again." in Log.

How to fix:

Go to Project settings -> Fields, look for Security level field, make sure that it doesn't hidden.

Then go to Project settings -> Screens. Add security level to screen "Create/Edit issue" for your issue type.

After that, you should see the lock on the screen and automation should work properly. 

0 votes
Alis-Hathway Ward (DO NOT USE) August 6, 2021

Seems like lots of things can cause permission type errors with automation, so adding my solve:

For me, it was failing when trying to apply a comment as the Automation for Jira user. It was saying that my commenter was not in our team group. Which makes sense because not a user. 

I had to click into the Then write a comment clause in the automation rules and there was a setting there for issue security! All I had to do was revert to the default issue security level.

Here's what that section in the automation rule looks like, if you're having trouble finding it. You have to click on the Then add comment to see it.

Screen Shot 2021-08-06 at 5.10.00 PM.png

0 votes
John Funk
Community Leader
Community Leader
Community Leaders are connectors, ambassadors, and mentors. On the online community, they serve as thought leaders, product experts, and moderators.
May 24, 2020

Hi @Vinicius Correia  - Welcome to the Atlassian Community!

Did you find your problem with the permissions?

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
PRODUCT PLAN
STANDARD
PERMISSIONS LEVEL
Site Admin
TAGS
AUG Leaders

Atlassian Community Events