Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
Level
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Failed to execute goal org.apache.maven.plugins:maven-compiler-plugin:3.5.1:compile

Hi guys, Ive been following this tutorial - https://developer.atlassian.com/server/framework/atlassian-sdk/create-a-helloworld-plugin-project/ 

but when trying to atlas-run on myplugin directory I get this:

Capture.PNG

3 answers

Just for anybody finding this in future the way I fixed this was to add the following to the pom.xml :

<plugin>

                <artifactId>maven-compiler-plugin</artifactId>

                <version>3.1</version>

                <configuration>

                    <source>1.8</source>

                    <target>1.8</target>

                    <fork>true</fork>

                    <executable>C:\Program Files\Java\jdk\bin\javac</executable>

                </configuration>

</plugin>

thanks that resolved my issue

Hey Wiliam,

it seems seems your JRE_HOME / JAVA_HOME points to a "default" JRE instead of a JDK. Did you tried to solve that?

 

Cheers,

Julian

Hi Julian Thanks for the response I think I've set it up correctly as per the tutorial?

Is there anything else that would be helpful to share at this stage?

Capture.PNG

0 votes

Hi @Will C

Is java 9 officially supported? can you try it with the latest java 8 version.

Cheers

Hi Carlos, I started with version 8 but that didn't work which is when I tried to use version 9, i've moved back to version 8 now and still get the same problem.

Sorry to hear that, here is my setup in case it could help you

Screen Shot 2018-02-07 at 23.04.35.png

cheers

Thanks Carlos, think your screenshot might have helped, seems my java home is pointing at the atlassian plugin sdk \ jre rather than my own java install. whats the easiest way to change this? also hoping my cmd error at the bottom isnt too much to worry about?Capture.PNG

I would say check your system and user variables. I just installed this in a virtual machine and after installing the Atlassian SDK it created a JAVA_HOME entry in user variables pointing to the Atlassian SDK path (remove it) after that this my atlas-version result:

Screen Shot 2018-02-07 at 23.47.16.png

and here is my current system and user variables

Screen Shot 2018-02-07 at 23.48.56.png

 

And my current path configuration for CMD i guess

Screen Shot 2018-02-07 at 23.50.11.png

Cheers

Suggest an answer

Log in or Sign up to answer
TAGS

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you