Can't send email - "530 Client was not authenticated"

I'm using JIRA 4.1.2 and have a JNDI smtp setup very similar to what the JIRA documentation describes:

<Resource name="mail/JiraMailServer"

auth="Container"
type="javax.mail.Session"
mail.smtp.host="mail.yourcompany.com"
mail.smtp.port="25"
mail.transport.protocol="smtp"
mail.smtp.auth="true"
mail.smtp.user="jirauser"
password="mypassword"
/>
</Context>
However, email refuses to work. I always get "530 5.7.1 Client was not authenticated".
We've tried these settings both in JNDI and through the UI. Now, we have a 4.4 JIRA app that works perfectly. We used the same email settings (in the UI) but the 4.1.2 app will not connect. Is there a known issue with 4.1.2 and mail?
Here is some of my mail debug output:
DEBUG SMTP: connected to host "<hostname>", port: 25
EHLO <servername>
250-SIZE
250-X-ANONYMOUSTLS
250-AUTH NTLM
250-X-EXPS GSSAPI NTLM
Can anyone think of any reason I can't connect? I'm also using java mail 1.4.1, which wasn't supposed to play well with NTLM. But why would my other JIRA instance work??
Thanks for any input! I'll give you ALL my karma if you can help me!! :-)

2 answers

1 accepted

Accepted Answer
0 votes

My solution to the was to upgrade my javamail jar from 1.4.1 to 1.4.6. I was able to connect fine after that!

Hi there,

I've found some other cases that indicate that this issue can be related to setting the SMTP server in JIRA not using an encrypted protocol. Aparently some SMTP servers require encrypted connection.

I know, it doesn't explain why it would work in the new version of JIRA using the same settings, but I think it'd worth a shot.

For this test, you may want to see this documentation. Alternatively, you can add some extra start up parameters to your JVM for encrypted communication during the authentication phase - mail.smtp.starttls.enable.

This parameter is set up during the start up phase. More info about that can be found in Setting properties and options on startup.

I hope this helps.

Cheers

Thanks for your response! However, since I know for sure our SMTP port is 25, doesn't that mean we can't be using an encrypted connection?? And I already tried the starttls parameter... :-(

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Sep 25, 2018 in Jira

Atlassian Research Workshop opportunity on Sep. 28th in Austin, TX

We're looking for participants for a workshop at Atlassian! We need Jira admins who have interesting custom workflows, issue views, or boards. Think you have a story to sha...

469 views 7 5
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you