Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root


1 badge earned


Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!


Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.


Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!


CSV import sub-task-link "Cannot find imported issue key"


Hi all,

I've burned a lot of time reading different posts on similar issues and trying different things to eliminate the problem but I'm still getting the same issues:

Unable to link issue from autoid-4597272455392040249 to 4 with link named 'sub-task-link': Cannot find imported issue key for external id 'autoid-4597272455392040249'

My csv file includes Issue ID and Parent ID, and for the subtasks, the Issue ID cell is left blank (and vice-versa for Parent ID).  

I even just tried generating my own Issue Keys but got the same exact errors.

Ultimately I'm importing in previous Asana task details if that helps at all.


Please help! 

2 answers

0 votes
Luis Dufour
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
Sep 22, 2023

I encountered the same error, and it was caused by a parent ID that did not exist in the CSV file at the time of import.

0 votes
Petter Gonçalves
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
Jun 01, 2020

Hello @Shannon Griffin

Welcome to Atlassian Community!

I'm not sure if I understood what exactly you are trying to achieve, but it seems you are trying to import issues through CSV as sub-tasks of other existing issues in your Jira site. Is that correct?

Please, allow me to provide you with some concepts and ask some questions so we can better confirm we are on the same page here:

1 - Are you using a Next-gen or Classic project?

2 - By the error returned to you, it seems you are trying to import the issues using the default issue linking, which is different from the link between sub-task and parent issues.

Can you please confirm if you have configured the CSV field with the same structure detailed in the section "Creating sub-tasks" of the documentation below?

Importing data from CSV 

3 - Can you provide us with the CSV you are trying to import? Please, make sure you hide all the sensitive information from it.

Let us know if you have any questions.

Hi @Petter Gonçalves,

Thanks so much for responding. I'm not trying to add subtasks to existing tasks, but rather adding tasks and their subtasks at the same time to a new/empty board.

1 - Next-gen

2 - I'm not sure I understand but I'm trying to import tasks and their subtasks together at once. (Migrating historical task data from Asana to Jira.)

3 - Absolutely. I've redacted any sensitive information from my tester file. Not seeing where to upload but if I can't find it, I'll provide a link here

Thank you so much!

Petter Gonçalves
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
Jun 04, 2020

Hello @Shannon Griffin

Thank you very much for the detailed explanation and details provided.

I took a look at your CSV file and I found the following details:

  1. The summary field is not properly filled for your sub-task issues. To properly import any issues, the summary field must contain a valid value for all issues in the import file as described in the CSV import documentation.
  2. I see you have a column called "Parent Id (2)", which seems to be returned a text value and another "Parent ID" column, which is correctly mapping the sub-task link. Just to confirm, you are mapping the column "Parent ID" in the import client to create the sub-task relation, right?
  3. The CSV import does not properly work for Next-gen projects due to several bugs, as mentioned in the link below:
    Unable to perform direct migration of the project from cloud to cloud due to CSV import bugs with Next-Gen projects 

Feel free to vote and watch the bug to increase its priority and also receive notifications about its fix implementation.

While we work to fix those bugs, please confirm the steps 1 and 2 are properly addressed and import your issues to a Classic project, properly moving them to your next-gen project afterward.

Let us know if it works for you.

Hi @Petter Gonçalves,

Thanks so much for checking it out.

1. Okay, I thought the summary field would only be for the tasks rather than the subtasks. I resolved that: mapped the Jira "Summary" to the Name column in my file which is where I derived the Summary column that I created in my file.

2. That's correct. I'm mapping Parent ID to Parent Id (the Parent ID (2) is extra and not being used).

3. I added my vote but I'll need to finish this before that gets enough traction and it's a one-time thing so that won't help me but hopefully it will help someone else.

I'm now wondering if I'm missing something around the way I have Sub-tasks set up? Because these are now the errors I'm receiving.
It essentially knows that it's a subtask because it's assigning the correct base number (SUB-102 > SUB-1021). 

  • Issue 'SUB-1020' is not of a sub-task type (Task). It will NOT be a sub-task of the issue 'SUB-102'
  • Issue 'SUB-1021' is not of a sub-task type (Task). It will NOT be a sub-task of the issue 'SUB-102'
  • Issue 'SUB-1022' is not of a sub-task type (Task). It will NOT be a sub-task of the issue 'SUB-102'
  • Issue 'SUB-1023' is not of a sub-task type (Task). It will NOT be a sub-task of the issue 'SUB-102'
  • Issue 'SUB-1024' is not of a sub-task type (Task). It will NOT be a sub-task of the issue 'SUB-102'

I also noticed I'm not able to set up a Sub-task at all or change the Tasks to Sub-tasks.

I feel like I'm aaaaalmost there! Thanks again for your help!



Petter Gonçalves
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
Jun 08, 2020

Hello @Shannon Griffin

Thank you for the details provided.

By the description of your error, it seems the system is not recognizing the sub-tasks listed in your file as sub-tasks, but as a standard-issue type.

Please confirm the steps below:

  1. Confirm that you are importing your issues to a Classic project
  2. The Sub-tasks from Classic projects and Next-gen projects have different names by default. Although this is customizable, this issue types are initially referenced as "Sub-task" in Classic projects and as "Subtask" in Next-gen projects.
    I see that your file was initially configured with the "Subtask" issue type, so can you please confirm you are referring to the correct sub-task name added under project settings > Issue types of the classic project you are trying to import the issues to?

Let us know if this information helps.

Hi @Petter Gonçalves

Yeah, that seems to be the case.

  1. No, I'm using Next-gen. You mentioned there's a bug and I upvoted the petition, but maybe I misunderstood the implications of the issue with Next-gen. Does that mean it's a lost cause?
  2. Correct. For my "Issue Type" field that I have mapped to Jira's "Issue Type" field, I have "Task" and "Subtask" in the column for each row. And it's clearly recognizing them on some level because for my Tasks, it's naming them, for example, SUB-103 and SUB-201, and for Subtasks they will have a fourth number and associated with the correct task like SUB-1034 and SUB-2012.

If it's a lost cause using Next-gen, then I can just start over with Classic and there shouldn't be any issues, right? Any suggestions or advice for that, let me know!



Petter Gonçalves
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
Jun 09, 2020

Hello @Shannon Griffin

Indeed, the bugs I mentioned about Next-gen projects cause the sub-tasks to not be mapped as an issue type in the CSV import, so it is not possible to import sub-tasks to Next-gen projects. Sorry if I wasn't clear about this.

Just like I mentioned before, a possible workaround if you want to use a next-gen project would be to import your sub-tasks to a Classic project and then move them to your next-gen project afterward.

That being said, I believe there will be no problems importing your current CSV data to a Classic project, just make sure you have mapped the correct sub-task issue type in the column.

Let us know if that works for you.

Hi @Petter Gonçalves

I created a new board - a Classic one - created new fields to account for the ones I needed to map, and they were imported and recognized as Subtasks. 
They did, however, map to the Backlog rather than with their Task / Parent ID to the correct Column. I've searched but everything I find seems out of date where the setup isn't the same. 

Also, I spent a few hours last night trying another method of keeping the information needed with the task by pulling the subtask details into one column of the task and creating a new paragraph field and just tried to map that column to that new paragraph field and pulled out the subtasks to remove any possible confusion. Then for that, it would pull the other fields but not the new custom field. This was in Next-gen as we're trying to stick with Next-gen. Any help understanding why a custom field would just not map, show no errors, and just pull nothing?

Could I please have you or someone else hop on a zoom call so I can finally get this resolved? I would sincerely appreciate that.



Petter Gonçalves
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
Jun 12, 2020

Hello @Shannon Griffin

I'm glad to know you were able to import your issues as sub-tasks.

Since the community is a public portal, I suggest opening other questions about each of the other behaviors you are facing that are not working as you expect, so we can better organize it and the answers could be easily found by other users that might be facing the same question. 

Additionally, In order to provide you with more specific information and instructions about your scenario, we suggest you open an internal support ticket with us at the portal below: 

In that internal ticket, we will be able to have a better understanding and view of your current scenario and how you can achieve what you need.

Let us know if there is anything else we can help with.

Hmm. Okay, so I guess I'll go post new questions for these and post a link to this convo to provide the context. I have to say that's a bit disheartening that I'm having to essentially start over as this project is now taking much longer and it's still not resolved.

Let us know if there is anything else we can help with. > Any answers you can provide here on the questions I had in my last thread would be the most help. 

I did follow the link you provided and submitted an internal ticket. 

Petter Gonçalves
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
Jun 19, 2020

Hello @Shannon Griffin

I'm sorry to see you felt disheartening about the community approach, it was not my intention to cause you this feeling. Please, allow me to clarify a few concepts about the Community channel:

As you know, the Atlassian Community is a public channel. The goal of the Community is to provide solutions that can help multiple/maybe thousands of Atlassian Users with a single shot, so it's required that all the discussions and solutions provided are strictly related to the initial question title and description to ensure it will help other users facing the same problem.

That being said, the initial issue you provided at the title and description seems to be solved, however, you have found posterior behaviors when importing sub-tasks that did not work as you expected. 

In order to ensure this community thread does not get too long with unrelated information that would not help the users that searched for the initial question title, we need to create new questions to properly address your new requirements or open an internal ticket where we will be able to get a closer look in your site and provide you with all the assistance you need in more efficient timing.

Please, let us know if you have any other questions in the Community (not addressed as an internal ticket) that I can help with.

Hey @Petter Gonçalves

Yeah, that's understandable. I followed your instructions on submitting a ticket but not sure how long that's going to take so we're just going to move forward without having the history imported for the time being. 

Thanks for all your help.


Suggest an answer

Log in or Sign up to answer
Site Admin
AUG Leaders

Atlassian Community Events