Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

CSV import fails with Fatal error during import in Jira

Hello, 

I want to do a JIRA creation test with comment via a CSV import.

In my CSV file, I put the following data : 

 

Summary,Issue Type,Assignee,Reporter,Comment
TEST CREATION JIRA IMPORT AVEC COMMENTAIRE,Bug,pack_45,scaroline.prt,"22/03/2020 5:06 AM;touengue; This comment works"

 

In my configuration file, i put the following configuration : 

 

"Comment" : {
"jira.field" : "comment"
},

 

The validation process does not return an error

But the import fails with a message "Fatal error during import". 

 

The below stack trace can be seen on the logs : 

 

2021-12-09 11:28:24,939 INFO - Importer started!
2021-12-09 11:28:24,940 INFO - Engine is running in Import mode
2021-12-09 11:28:24,941 INFO - Comment was detected as a format Date;[Author;];Comment, however and exception occurred while parsing comment. Some values may not be set. Exception: Unparseable date: "22/03/2020 5:06 AM"
2021-12-09 11:28:24,941 INFO - All issues will be imported to project: ICDCEXT_RQM (ICDCEXT_RQM)
2021-12-09 11:28:24,941 INFO - Creating issue: [externalId='autoid-1359876721498032177', summary='TEST CREATION JIRA IMPORT AVEC COMMENTAIRE']
2021-12-09 11:28:25,139 ERROR - Fatal error during import
java.lang.NullPointerException
	at com.atlassian.jira.plugins.importer.imports.bulkcreate.engine.BulkCreateDataImporter.doImportIssues(BulkCreateDataImporter.java:235)
	at com.atlassian.jira.plugins.importer.imports.bulkcreate.engine.BulkCreateDataImporter.runImporterEngine(BulkCreateDataImporter.java:172)
	at com.atlassian.jira.plugins.importer.imports.bulkcreate.engine.BulkCreateDataImporter.doImport(BulkCreateDataImporter.java:147)
	at com.atlassian.jira.plugins.importer.imports.importer.impl.ImporterCallable.call(ImporterCallable.java:26)
	at com.atlassian.jira.plugins.importer.imports.importer.impl.ImporterCallable.call(ImporterCallable.java:15)
	at com.atlassian.jira.task.TaskManagerImpl$TaskCallableDecorator.call(TaskManagerImpl.java:533)
	at com.atlassian.jira.task.TaskManagerImpl$TaskCallableDecorator.call(TaskManagerImpl.java:491)
	at java.base/java.util.concurrent.FutureTask.run(FutureTask.java:264)
	at java.base/java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:515)
	at java.base/java.util.concurrent.FutureTask.run(FutureTask.java:264)
	at com.atlassian.jira.task.ForkedThreadExecutor$ForkedRunnableDecorator.run(ForkedThreadExecutor.java:216)
	at java.base/java.lang.Thread.run(Thread.java:834)

 

When I remove the data in the Comment column, the issue is created. 

 

I have tried different formats for the date but without success

 

If you have any ideas for how to fix this, let me know.

 

Thank you for your help.

 

 

 

 

 

2 answers

1 accepted

0 votes
Answer accepted

Hi @Thibault_O. 

It works fine for me without a configuration file when I used the "External System Import" under the System menu in the Admin. My comment was like this:

"05/05/2010 11:20:30; adam; This is a comment."

Mapping:

mapping.jpg

HTH,
KGM

Hi @Kristjan Geir Mathiesen - Origo ,

This screenshot made me realize that I am not mapping to the correct field.
As I do not have access to "External System Import" under the System menu in the Admin, I do not have access to this data in the mapping.
So I will first see with an administrator to map with this field.

Probably after this change it will work.


Thank you for the answer.

0 votes
Alexis Robert Community Leader Dec 09, 2021

Hi @Thibault_O. ,

 

have you tried without using a Configuration file ? It's usually generated automatically after the import, so you can use it for the next one.

 

Let me know if this helps, 

 

Alexis

Hi @Alexis Robert ,

 

I just tried without the configuration file and I have the same error. 

Thanks to @Kristjan Geir Mathiesen - Origo's screenshot , I think I know where the problem comes from: I am not mapping to the right field. Indeed, on its screenshot, @Kristjan Geir Mathiesen - Origo  is mapping on the "Comment body" field while I am mapping on the "Comment" field. 

 

Thank you for answering.

@Thibault_O.  great to hear that this is solved! Please mark this answer as correct.

Thank, you,

KGM

Suggest an answer

Log in or Sign up to answer
TAGS

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you