Backlog empty on Scrum board

I have recently installed JIRA 5.1.7 and GreenHopper 6.0.6 to review the recent changes to the boards. However, I am being faced with an empty backlog even though the project has a number of sample issues created during the project creation step.

The message visible in the backlog is "There are currently no issues in the backlog"

I have checked the filter and it appears ok. What else could be causing this to happen?

7 answers

1 accepted

This widget could not be displayed.

The following KB has been created which rectifies the issue:

https://confluence.atlassian.com/display/GHKB/Empty+Backlog+Even+Though+Issue+Exist

This widget could not be displayed.

I recently had the same issue in JIRA v6.1 and Agile v6.3.1.

The solution for me was to fix the mis-match in column mapping between the different workflows.

If you go to: Board -> Configure -> Columns and check if you have any issue statuses unmapped. Drag them to one of the predefines statuses, and you should be ok.

Thank you - this was the correct answer for me. Have read about 20 threads, so very happy to finally have the answer. Very helpful.

Glad I could help :)

This was my issue and fixed my problem immediately.

This widget could not be displayed.

Hi Alan,

Perhaps, the message is display wrongly. For more information, you may refer to this improvement ticket GHS-6427. I suggest to vote on it and add yourself in the watch list to keep you updated in future.

Good luck.

Regards,

John

This widget could not be displayed.

Hi Alan,

Please check the following:

  • The issues your filter matches must be in a status which is mapped to a column on the board (and not the last column which is considered 'Done')
  • The issues aren't in an active sprint (in which case they will be in Work mode)
  • You don't have any quick filters active

If you find the problem is the first one (i.e. the statuses) please let us know because you should get a warning about this in the Filter section of the configuration for the board.

Thanks,
Shaun

The filter matches issues which map to columns on the board - this is visible when I go into the 'Configure' screen for the board as each column has a number of issues attributed to it.

There are no sprints configured yet, however if I configure a sprint, it makes no difference. The Backlog section in the Plan screen continues to show "There are currently no issues in the backlog".

Any ideas?

Very weird, I'd suggest logging an issue with support at https://support.atlassian.com, they can help diagnose what's going on.

Thanks,
Shaun

This widget could not be displayed.

do you have Epics enabled in Greenhopper Labs?

i was facing the same problem...the epic sidebar on greenhopper view had an unlabeled epic highlighted wich causes an empty backlog view cause none of the existing issues were grouped among it

Thanks, but I've just posted the fix for my problem, was a weird data issue with the custom fields.

This widget could not be displayed.

Per the second resolution at the very bottom of this article

https://confluence.atlassian.com/display/GHKB/Your+issue+XXX+has+been+created+but+is+not+currently+visible+on+the+Rapid+Board

go to Administration -> Issues -> Fields

then scroll down the custom fields till you get "Sprint" field used by Greenhopper.

Check to see that it has been applied to your project, or that it is set to apply to all projects

by using the "Global" setting

That was already suggested by the support staff, but didn't help in this situation. The KB article I posted solved this problem.

@alan, well it was definately the problem for me. clearly if your project's issues do not have the 'sprint' field which is used by greenhopper then it won't work, regardless of what else may be wrong. btw, i re-indexed and then i think i recreated the board afterwards to get it to pick up the new field, not 100% sure on the necessity of that lest step though.

My projects did have the sprint field used by GreenHopper and still didn't work. That was the problem which this topic is about and which the KB marked as the answer solves.

@alan, i understand that it didn't solve your problem, but your question is generic enough that someone with my problem could easily land on this question, just as I did. If, as a customer, finding the resolution to your problem is the primary purpose of these forums, then I think it's appropriate enough.

This widget could not be displayed.

Per the second resolution at the very bottom of this article

https://confluence.atlassian.com/display/GHKB/Your+issue+XXX+has+been+created+but+is+not+currently+visible+on+the+Rapid+Board

go to Administration -> Issues -> Fields

then scroll down the custom fields till you get "Sprint" field used by Greenhopper.

Check to see that it has been applied to your project, or that it is set to apply to all projects

by using the "Global" setting

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Tuesday in Jira

What modern development practices are at the heart of how your team delivers software?

Hey Community mates! Claire here from the Software Product Marketing team. We all know software development changes rapidly, and it's often tough to keep up. But from our research, we've found the h...

199 views 1 3
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you