Atlassian Connector 1.3.10 & VS2010: HTTP error "(417) expectation failed"

Hello,

I'm unable to add our JIRA server into the VS integration (Atlassian Connector, just downloaded) with the abovementioned error. I can reach JIRA without problems using the same address via the browser, and I double-checked my credentials.

The error details:

Failed to connect to server "GEBIT JIRA"

Der Remoteserver hat einen Fehler zurückgegeben: (417) Expectation Failed.<br><br>Url: http://jira.gebit-ms.de/rest/auth/1/session<br>Data: {"username":"xxxxxxxx","password":"xxxxxxxx"}

[...]

<h1>ERROR</h1> <h2>The requested URL could not be retrieved</h2> </div> <hr> <div id="content"> <p><b>Invalid Request</b> error was encountered while trying to process the request:</p> <blockquote id="data"> <pre>POST /rest/auth/1/session?os_username=xxxxxxxx&amp;os_password=xxxxxxxx HTTP/1.1
Content-Type: application/json
User-Agent: Atlassian-VS-Connector
Host: jira.gebit-ms.de
Content-Length: 47
Expect: 100-continue
Connection: Keep-Alive
</pre> </blockquote>

<p>Some possible problems are:</p> <ul> <li id="missing-method"><p>Missing or unknown request method.</p></li> <li id="missing-url"><p>Missing URL.</p></li> <li id="missing-protocol"><p>Missing HTTP Identifier (HTTP/1.0).</p></li> <li><p>Request is too large.</p></li> <li><p>Content-Length missing for POST or PUT requests.</p></li> <li><p>Illegal character in hostname; underscores are not allowed.</p></li> <li><p>HTTP/1.1 <q>Expect:</q> feature is being asked from an HTTP/1.0 software.</p>

[...]

System.Net.WebException

at Atlassian.plvs.api.jira.RestClient.jsonOp(String method, String tgtUrl, Object json, HttpStatusCode expectedCode)
at Atlassian.plvs.api.jira.RestClient.restLogin()
at Atlassian.plvs.api.jira.facade.RestJiraServerFacade.login(JiraServer server)
at Atlassian.plvs.api.jira.facade.SmartJiraServerFacade.<>c__DisplayClass2.<login>b__0(JiraServer param0)
at Atlassian.plvs.api.jira.facade.SmartJiraServerFacade.delegatedVoid(JiraServer server, DelegateVoid rest, DelegateVoid classic)
at Atlassian.plvs.api.jira.facade.SmartJiraServerFacade.login(JiraServer server)
at Atlassian.plvs.dialogs.jira.TestJiraConnection.testConnection()

What further information can I provide to enable you analyzing the issue?

Thanks, cheers,

Tim dos Santos

(by the way, I noticed that in the error details the username and password (!) are shown in plain text several times - you may want to change that asap! I removed my credentials in the above pasted snippet.)

2 answers

twimc, I updated to the latest snapshot version of the connector, but the problem persists. I also tried to access the REST-url directly in my browser (on the same machine as VS2010), and it successfully returns JSON data. So there must be some problem in the connector itself.

I worked around the problem by specifying another URL pointing to the same JIRA instance; must've been a problem with our reverse proxy or something. Never mind the noise...

Suggest an answer

Log in or Join to answer
Community showcase
Sarah Schuster
Posted Jan 29, 2018 in Jira

What are common themes you've seen across successful & failed Jira Software implementations?

Hey everyone! My name is Sarah Schuster, and I'm a Customer Success Manager in Atlassian specializing in Jira Software Cloud. Over the next few weeks I will be posting discussion topics (8 total) to ...

2,760 views 11 18
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot