Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

"Automation" Missing from Jira Cloud Software Project and System Settings

Edited

I'm attempting to migrate from Jira Server to Jira Cloud. I have a Jira Cloud site I set up a few months back I have imported my Jira Server data into, but Automation is not appearing in the System or Project settings. I created a new Jira Software Cloud in the last week or so and I can see the Automation tab in the system settings so I know where it should be, but does anyone know why wouldn't it be appearing in the older instance?

 

Screen Shot 2020-07-15 at 5.11.50 PM.pngScreen Shot 2020-07-15 at 5.12.03 PM.png

3 answers

1 accepted

1 vote
Answer accepted

Thanks for raising this, if it's a bug, it is likely my fault.

Automation should be showing under the "People" navigation item from the top screenshot. I can't think of a scenario where it wouldn't show other than Automation not being installed on the instance (which should not be the case). 

Please try navigating to global automation config. Hit the period key from most any screen in Jira "." and type "automation" into the resulting dialog. 

If you're not a global admin you can manually navigate to a project specific automation config by going to this URL:

https://{{yourAtlassianUrl}}.atlassian.net/plugins/servlet/ac/com.codebarrel.addons.automation/cb-automation-project-config?project.key={{projectKey}}&project.id={{projectId}}
wwalser Atlassian Team Jul 15, 2020

Yeah, it sounds like Automation isn't installed for some reason. Support request should help you get this figured out. Sorry about the trouble.

Unfortunately I can't file a support request since I'm on the free tier.

Given this is a bug on Atlassian's side is it possible you could start one for me? :)

wwalser Atlassian Team Jul 15, 2020

I am not able to start a support request but the problem is likely not isolated to just you so we're going to be strongly incentivised to find a general solution. 

To confirm 100% that automation is or is not installed, could you navigate to "Manage apps", you can get there via the dot menu ("." shortcut). Form there you'll be able to see what plugins are installed. Change the filter from user installed to system installed plugins:

Screen Shot 2020-07-16 at 3.16.22 pm.png

 

From there, check to see if Automation is in the list. It should look like this:

Screen Shot 2020-07-16 at 3.16.15 pm.png

 

That would help us to have higher confidence about exactly what is happening.

It doesn't appear to be installed.

 

Screen Shot 2020-07-15 at 10.40.09 PM.png

Here's the list filtered for "auto":

Screen Shot 2020-07-15 at 10.41.44 PM.png

Like wwalser likes this
wwalser Atlassian Team Jul 16, 2020

Based on conversations late in the day here (AU time) yesterday it sounds like we've fixed this for you.

wwalser Atlassian Team Jul 16, 2020

After the server->cloud migration there was some groups that needed approval to get things working properly. 

Hello wwalser,

Even I am facing the problem.
Can you please help me to get to automation tab?

Thank you,

@wwalser Do you have any additional information about the groups? We are experiencing the same issue after a server to cloud migration. Quite sure that we've overwritten some permission schemes regarding app's as we are also not able to install other apps.

 

Your answer would be much appriciated.

 

Edit: it has to do with a corruption of the `jira-software-users`; as it is not properly shown and selectable in `Product access`. Removing and adding the group fixed the issue of installing new apps, however automation is still not visible as of yet.

wwalser Atlassian Team Jan 24, 2021

Unfortunate that this is still occurring.

After the migration a manual reinstall of the Automation plugin should kick all of the necessary permissions in the right direction.

In Jira's header there should be a navigation item called "Apps". In that dropdown select "Manage you apps".

From the manage apps screen you should be able to "Upload app". After clicking that a dialog will show with at text box. Paste `https://automation.codebarrel.io/pro/atlassian-connect.json` into that text box.

If you can't see the "Upload app" link, you'll have to scroll to the bottom of the page and click "Settings" and check all the boxes in the resulting dialog, then refresh the page.

Screen Shot 2021-01-25 at 4.25.24 pm.png

Like Ferdy Perdaan likes this

@wwalser You're making my day! It may be sad that it doesn't work directly but your workaround is easy to apply and hardly an inconvenience. 

Thank you for your response.

Like wwalser likes this
wwalser Atlassian Team Jan 27, 2021

I'm glad that worked for you. Seems like migrations are still something we need to look into though. Would like to make sure it "just works". That is, obviously, the intention.

Hi Sorry to hijack this thread but I've just imported from a backup taken from the same cloud instance and also lost automation in seemingly an identical way. I've checked my groups and all have been reviewed/approved after the import, I've also tried logging off and back on after reviewing the groups.

Screenshots below seem to show a broadly similar issue.

Apps screen (no automation app)

Screenshot 2020-11-10 at 12.00.53.png
Error message when trying to access automation from the project settings screen.Screenshot 2020-11-10 at 12.01.11.png
No automation option within settings
Screenshot 2020-11-10 at 12.01.28.png

Hi @7Elements are you able to raise a support request for this problem? It doesn't appear to be the same thing that was affecting the OP.

I'm on the free plan so can't use support, if it's not the same worth starting a new thread?

wwalser Atlassian Team Nov 10, 2020

I can't do an in-depth analysis without a support case but I also don't like the fact that Automation is completely broken.

Please email me your instance URL so that I can investigate. My email address is the same as my username here at atlassian.

Hi, wwalser, having the same problem here :(

did you find the solution?

@wwalser  now i have this issue:

jiracloud issue.PNGAny known sloution for that?

 

 

Thanks,

wwalser Atlassian Team May 20, 2021
Hmmm, sorry about that.
I believe this is happening because there are not default groups for each product in your instance. The documentation presented in the link from that error is reasonable, though it could be more clear.
This usually happens after a site import. I think we prompt admins to select default groups after the import, but as there are many steps in that process it gets missed from time to time. An admin just need to pick some group, something like "jira-users" is a reasonable choice.
Like Marcal Martorell likes this

Cause: restoring from back-up. jira sometimes messes up with groups.

 

Solution:

1. go to user management (admin): Create a new group.

2. Go to product access (admin): Make the new group as default group for product access.

 

 

thanks,

0 votes
John Atlassian Team Jul 15, 2020

Hi @jonschneider ,

Jira automation has been rolled out to all Jira cloud instances. I haven't been able to replicate what you're seeing. Can you please raise a support request at support.atlassian.com, we should be able to help you further from there.

As a temporary workaround you can hopefully use the url to access automation:

yourinstance.atlassian.net/plugins/servlet/ac/com.codebarrel.addons.automation/cb-jira-automation-rules

Thanks,
John

Hey John,

For me that link returns an empty page with an error dialog. Unfortunately I'm on the free tier (I love using Jira as the world's most overpowered personal todo list) so I can't start a support request or file a bug report.

Screen Shot 2020-07-15 at 7.51.39 PM.png

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
PRODUCT PLAN
FREE
PERMISSIONS LEVEL
Site Admin
TAGS
Community showcase
Published in Jira

Admins, notify your Jira instance of system-wide changes with the new admin announcement banner

Hi All! We’re excited to share the launch of an announcement banner that lets Jira site administrators communicate directly to their users across their  Jira Cloud instance.  ...

391 views 13 14
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you