Removing story point estimate from sub-task card in active sprint

Pedram Mireftekhari
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Leaders.
February 20, 2020

I want to remove the story point estimate from the subtask card in an active sprint. I already have removed it from my fields config by associating sub-task to a field config, but still, on the Active Sprints board, it is visible. How can it be removed?

It is not visible on the sub-task issue view screen. Only on task level.

FL board - Agile Board - JIRA.jpg

1 answer

0 votes
Petter Gonçalves
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
February 21, 2020

Hello @Pedram Mireftekhari

Thank you for reaching out.

Per your description, I understand you are not planning to add any Story point estimation to the Sub-tasks in your board, however, the "-" keep appearing in the board cards. Can you please confirm if you are using a Next-gen or a classic project?

If you are using a Classic project, I believe the symbol you are pointing in your screenshots is not related to Story points, but to the remaining estimate (Time tracking) of your sub-tasks since Story points context are by default applicable only to Stories and Epics.

That being, please try the steps below to confirm this information:

1 - Navigate to your board > Click in the three dots icon at the top-right corner > Board settings

2 - Click in the tab Estimation > Set your estimation to be Story points, flagging the option "None" under time tracking:

Screen Shot 2020-02-21 at 16.12.55.png

If the instructions above didn't make that symbol disappear, check the following:

- under Jira settings > Issues > Custom fields > Find Story Points > Click "Context and default value"

- Check if the Story point context is applied to the sub-task issue type, removing it in case that's true. P.S: This might affect other projects too, so if you are planning to use Story points for sub-tasks in other projects or have multiple teams using it, make sure to configure a specific context for your project.

Let us know if you have any questions or if you are using a Next-gen board.

Pedram Mireftekhari
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Leaders.
February 23, 2020

Thanks for the explanation. I am using a classic project. However, I tried both of your solutions but I can still see that field visible in my project. I think the problem is with the story point context in the custom field.

I created a new context as bellow and assign it to my project with specifically applicable to Task issue type but still...

Is it because I have the second context? but that one is for another project 
Could it be because the Story Points field is associated with 12 screens in different projects?

Custom fields - JIRA.jpg

Marta Cardoso March 31, 2020

I have the exact same issue, and in my board the settings are already 'None' for time tracking. Like Pedram, I have two contexts - one for one project and a 'default' context.

Marta Cardoso March 31, 2020

It seems to have been fixed with this: I created a new screen without the story points field, added a screen scheme and in the configuration associated the new scheme with the subtasks.

Now no numbers/'-' shows up on the subtasks card, which is exactly what I wanted. @Pedram Mireftekhari not sure if this helps or if you had already fixed the issue!

Nick.Payton March 11, 2021

@Petter Gonçalves 

So I'm in the same situation here. 

I have a classic software project

the board settings "Estimation" is set to Story Points with "Time Tracking" set to None

I have a screen scheme setup for User Stories and Tasks, a scheme for Sub-Tasks, and a scheme for Epics.  Each scheme has their own unique Screen Configuraiton.

FIRST ISSUE:
The Screen configuration for Sub-Task does not even have the "Story Points" field in the list, yet I still see Story Points showing up in the Issue Type Layout under Project Settings...

SECOND ISSUE:
Attempted to solve again by moving "Story Points" Field to Hidden under issue type layout.  Still seeing this " - " in the sub-task type card on kanban board.

 

Nick.Payton March 11, 2021

AH!  Found it.  So as @Petter Gonçalves Mentioned - under the Jira Global Settings -> Fields -> Custom Fields Type in Story point.

You'll see that inherently Jira has two fields created for this:
story points.JPG

From here - you need to make sure that if Sub-Tasks are to have their own view on a Kanban board level, that you make a screen scheme and screen specific to Sub-Task issue type.  Then, make sure to configure your Screen for Sub-Task so that "Story Point" is not in that config.

For any issue type that you do wish to have story point estimates, make sure that you have that field added in the screen config.

Now returning back to this custom field context - AS mentioned by Petter, edit the context for "Story Points" and remove any issue types you do not want to have.  Make sure to note that this can impact other projects in your jira space.

Like Jessica Romero likes this
Jessica Romero
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
February 22, 2024

This was it! Thank you!

Suggest an answer

Log in or Sign up to answer