Jira All Logins Failed

After reboot all logins fail.

Any idea ?

 

 

1 answer

0 vote

What does the log say is wrong?

(If it is refused logins, the best guess is that the user directory is failing for some reason, but that really is a guess, as your question has so little information in it)

I  find this information in log: 

2017-07-17 16:05:54,592 ThreadPoolAsyncTaskExecutor::Thread 21 WARN      [o.hibernate.dialect.H2Dialect] HHH000431: Unable to determine H2 database version, certain features may not work

problem with database ?

That's not healthy, but I don't think it's fatal, and I don't think it's anything to do with your users logging in.

What do the logs say at the time someone tries to log in?  Refusal to let a user in is recorded, with a reason.

When I try to log in, the log says nothing.

the response of login is :

{"allowCookies":true,"externalUserManagement":false,"isPublicMode":false,"isElevatedSecurityCheckShown":false,"loginSucceeded":false,"captchaFailure":false,"loginError":false,"communicationError":false,"contactAdminLink":"please contact your JIRA administrators","loginFailedByPermissions":false}

Unless you've deliberately turned off all the logging, it is definitely logging your attempts to log in.  Have you checked the right log?  And all the others in there?

this is a log in  

atlassian-jira-security.log 

 

2017-07-17 20:21:15,446 ContainerBackgroundProcessor[StandardEngine[Catalina]] HttpSession [frkdno] destroyed for 'anonymous'
2017-07-17 20:21:39,057 http-nio-8080-exec-7 anonymous 1221x46x1 - 89.115.147.164,66.249.81.176 / HttpSession created [gcf866]


2017-07-17 20:21:43,030 http-nio-8080-exec-5 anonymous 1221x81x1 - 89.115.147.164 / HttpSession created [13x9u14]

 

That looks odd, mine says stuff like:

2017-07-17 21:35:45,175 http-nio-2990-exec-9 anonymous 1295x47x2 z19bht 0:0:0:0:0:0:0:1 /rest/gadget/1.0/login login : 'nic' tried to login but they do not have USE permission or weren't found. Deleting remember me cookie.
2017-07-17 21:35:45,227 http-nio-2990-exec-9 anonymous 1295x47x2 z19bht 0:0:0:0:0:0:0:1 /rest/gadget/1.0/login The user 'nic' has FAILED authentication.  Failure count equals 1

i can make a new setup and copy the database?

 

 

You can, but I don't know how it will help.  You've not established what the atual problem is.

You need to look at the errors in the logs at the time you try to log in - explicitly test a user and enter the wrong password to check that you get something similar to waht I got in my security log (or another error)

I have some errors in Catalina.out

 

2017-07-18 12:55:06,764 JIRA Warmer Thread:thread-1 INFO [c.a.jira.i18n.I18nWarmer] Initialised i18n cache in 1604
2017-07-18 12:55:15,816 Caesium-1-1 WARN [c.a.a.c.hash.reader.RemoteHashingInstructionsReader] Unable to read remote instructions with key 'uid.onewayhash'.
2017-07-18 12:55:15,817 Caesium-1-1 WARN [c.a.a.client.hash.BcryptAnalyticsEmailHasher] No instructions for hashing could be found.
2017-07-18 12:55:19,223 hipchat-client:thread-1 WARN [c.a.p.hipchat.token.DefaultHipChatTokenRefreshService] Token with name [AddonToken(1)] refresh failed with status code [500]. Error message [com.sun.jersey.api.client.ClientHandlerException: java.net.UnknownHostException: api.hipchat.com]. Turn on debug mode to see stack trace.
2017-07-18 12:55:19,260 hipchat-client:thread-2 WARN [c.a.p.hipchat.token.DefaultHipChatTokenRefreshService] Token with name [AddonToken(1)] refresh failed with status code [500]. Error message [com.sun.jersey.api.client.ClientHandlerException: java.net.UnknownHostException: api.hipchat.com]. Turn on debug mode to see stack trace.
2017-07-18 12:55:19,270 Caesium-1-1 ERROR [c.a.p.hipchat.ping.DefaultConnectionStatusService] Got an error trying to get the status of the connection
com.atlassian.cache.CacheException: com.google.common.collect.ComputationException: com.google.common.collect.ComputationException: java.util.concurrent.ExecutionException: com.sun.jersey.api.client.ClientHandlerException: java.net.UnknownHostException: api.hipchat.com
at com.atlassian.cache.memory.DelegatingCachedReference.get(DelegatingCachedReference.java:84)
at com.atlassian.cache.compat.delegate.DelegatingCachedReference.get(DelegatingCachedReference.java:22)
at com.atlassian.plugins.hipchat.ping.DefaultConnectionStatusService$3.apply(DefaultConnectionStatusService.java:181)
at com.atlassian.plugins.hipchat.ping.DefaultConnectionStatusService$3.apply(DefaultConnectionStatusService.java:167)
at com.atlassian.fugue.Option$Some.fold(Option.java:421)
at com.atlassian.plugins.hipchat.ping.DefaultConnectionStatusService.requestConnectionStatus(DefaultConnectionStatusService.java:160)
at com.atlassian.plugins.hipchat.ping.DefaultConnectionStatusService.getConnectionStatusInner(DefaultConnectionStatusService.java:152)
at com.atlassian.plugins.hipchat.ping.DefaultConnectionStatusService.getConnectionStatus(DefaultConnectionStatusService.java:246)
2017-07-18 12:55:59,988 Caesium-1-4 DEBUG [c.a.activeobjects.osgi.ActiveObjectsServiceFactory] getService bundle [com.atlassian.support.healthcheck.support-healthcheck-plugin]
2017-07-18 13:25:03,966 Caesium-1-2 DEBUG ServiceRunner [c.a.activeobjects.osgi.ActiveObjectsServiceFactory] getService bundle [com.atlassian.jira.plugins.jira-development-integration-plugin]
 

And the errors in the other logs?  The ones that *always* get written to?

Problem solved 

Update to last version.

 

Tks

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Sarah Schuster
Posted Mar 28, 2018 in Jira Software

Can a company’s culture make or break agile adoption?

Can a new-to-agile team survive and thrive in a non-agile culture? If so, what advice would you give to those trying to be agile in a non-agile culture? What's the key(s) to success? Share your thoug...

12,051 views 15 13
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you