How can I update a field value on the initial save/submission of a ticket?

Esther Strom
Community Leader
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September 20, 2019

Somehow I've never needed to do this in 7 years as an admin...

I've been asked to create a simple workflow with the following statuses:

  • Pending Supervisor Approval (which is the initial status of a newly-created issue)
  • Supervisor Approved
  • Supervisor Denied

No problem. We have a custom user picker field on the screen for supervisor. What I need to happen, that doesn't seem to be working, is for the issue to be immediately assigned to the supervisor as soon as it's submitted. 

I've edited my Create incoming transition to have a post function to copy the supervisor value into the assignee field, but that isn't happening. 

 

2019-09-20_1526.pngWhere am I going wrong here? How do I capture the event of "saving" the issue for the first time?

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Mohamed Adel
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September 21, 2019

@Esther Strom 

I think your problem exist with the post-fucntion order. as per this Post-function on Create Issue transition appears to not work

Cause

Any post functions placed after the "Creates issue originally" function will not have updates to the issue persisted to the database.

Resolution

Re-order the post-functions such that the new post-function comes before the  "Creates the issue originally" post-function.

Esther Strom
Community Leader
Community Leader
Community Leaders are connectors, ambassadors, and mentors. On the online community, they serve as thought leaders, product experts, and moderators.
September 23, 2019

Thank you! That did it.

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