Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Atlassian Universal Plugin Manager update bug

I have a Jira Software (Server) 10 Users - Starter License.

In the "Manage App" section system ask to update Atlassian Universal Plugin Manager to version 3.0.3 even if version 4.0.1 is installed.

JIRA.png

 

Regards.
Davide.

3 answers

2 accepted

1 vote
Answer accepted
Andy Heinzer Atlassian Team May 01, 2019

Hi Davide,

Thanks for reporting this.  We are actually tracking a related bug for this over in UPM-5985.  I agree that this seems confusing.  I would try to avoid updating the UPM until this is resolved.  I suspect that the marketplace listing for the UPM might have an error that is causing this update to be prompted to Jira 8.1.x users when they already have a major version higher than the version being offered to them.

Andy

Hi Andrew.

Thanks for your reply.
I will wait until the problem is solved ;-)


Good day and good work.
Davide.

0 votes
Answer accepted
Andy Heinzer Atlassian Team May 06, 2019

Hi Davide,

Sorry to hear this problem persists.  I created a support case so that we can gather some more data about your Jira install here.

Please see https://getsupport.atlassian.com/servicedesk/customer/portal/20/GHS-151057 for details.

Regards,

Andy

Thanks Andrew!

Hi Andrew!

30 minutes ago system noticed a new update for Atlassian Universal Plugin Manager to version 4.0.4 (4.0.1 installed).

However, when I update, the system return this message


JIRA-UPMError.png

In the next image, the APP LOG result:

JIRA-UPMError-2.png

Andy Heinzer Atlassian Team May 02, 2019

Hi Davide,

Sorry to hear you are seeing this problem.  I would recommend trying to following steps when you have some time when you can stop Jira.

  1. Stop Jira
  2. Go the $JIRAHOME/plugins/installed-plugins/ directory
  3. Find all plugin in here by the name 'universal plugin manager' and remove these.  I suspect you will have at least one entry, but it's possible you could have several here.  You can move these to a temp folder outside the $JIRAHOME
  4. Start Jira again

This will force Jira to use the bundled UPM version on startup.  From there you should be able to update this successfully within Jira once more.

Regards,

Andy

Hi Andrew.

I followed your instructions.

I stopped Jira.
In $JIRAHOME/plugins/installed-plugins/ directory I found a file with name "upm-xxxxxxxx".So I move it in temp folder outside $JIRAHOME and restart Jira.

But when i try to update UPM plugin, same error is show.

Regards.
Davide.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Posted in Jira Software

Presenting the "Best of 2020" Jira Software roundup!

Catch up with Atlassian Product Managers in our 2020 Demo Den round-up! From Advanced Roadmaps to Code in Jira to Next-Gen Workflows, check out the videos below to help up-level your work in the new ...

305 views 2 7
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you