It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Atlassian Fix for Cleaning XML backups not Working

I'm trying to follow the second solution provided in this KB article but whenever I run the line 

java -jar atlassian-xml-cleaner-0.1.jar entities.xml > entities-clean.xml

I get the following output:

 -rbash: entities-clean.xml: restricted: cannot redirect output

 I've given everyone rwx permission on all files and I've even tried running this as the superuser, but I still get this output every time. Does anyone have any idea why this might be happening?

1 answer

1 accepted

1 vote
Answer accepted

This is down to your use of rbash for your shell - that restricts many of the functions that bash (and most other shells) do.

One of the things rbash prohibits is the use of redirection of output, the > in your command.

I think you'll need to run the command in a less restricted shell.

Thank you for clearing that up! I ended up switching to the root user and then running the command 

java -jar atlassian-xml-cleaner-0.1.jar entities.xml > entities-clean.xml

It immediately worked. Thank you! 

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
SERVER
VERSION
8.8.0
TAGS
Community showcase
Published in Jira Software

How to create Jira issus from Excel file?

When to use CSV importer When managing your processes in Jira, there are many occasions where you need to create a lot of tasks. Creating them one by one will cost you a lot of time and effort and i...

3,766 views 15 27
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you