Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

ticket replies come with the wrong email sender

i have defined in the project, that the email is support@ourdesk.altassian.com

1. when an user sends an email to this email address, a ticket is created

2. when an agents replies to this email, the email is sent to the customer and the reply email is correct.

3. when the customer then replies to that email, the comment is created in that ticket.

4. and now the problem is: when the agent replies the second time in this ticket, the email sender is jira@ourdesk.altassian.com.

.. when the customer replies to this, nothing comes in our ticket system ...

can someone help to fix this?

i have a default configuration, did nothing special, just defined the email in projectsettings, thats all.

1 answer

Hi @Michael Roth 

What do the logs say? There is a link to view logs on the default email address. 

Also what is your email request type (to find it click the ... at the top right and select Configure email request type

 

-Mike

there is no log for emails that are sent to jira@ourdesk.atlassian.com

there is only a log for support@ourdesk.atlassian.com, that i can find under Project settings/Channels/Email ... but the emails sent as reply to jira@ are not logged there.

i dont know what you mean by ... at top right ?

under Project settings/Request types/Email request

there is no possibility to set an email and there is no ... anywhere ?

Hi @Michael Roth 

 

I am able to replicate what you have said, but this is why or how it happened:

  1. Customer sends email to sesd@ourdesk.atlassian.net and it arrives in our All Open Queue. = correct behavior.
  2. Ticket is not assigned, but an agent replies in the comments and an email is sent back to the customer from sesd@ourdesk.atlassian.net = correct behavior. 
  3. Customer replies to that email (sesd@ourdesk.atlassian.net) and a comment is added to the ticket. = correct behavior. 
  4. Agent assigns the ticket to themselves and adds a further comment to the ticket and the customer this time around receives an email from the agent with jira@ourdesk.atlassian.net. = correct behavior.  
    email 2.png
  5. However when the Customer replies (note the header below) and my question to you? Did the customer manually type in jira@ourdesk.atlassian.net because that is what they saw against the Agents name or did they simply reply again as per normal (sesd@ourdesk.atlassian.net)? 
  6. Also what email client is the customer using.... I can say for certain if Gmail was used the reply-to address is definitely sesd@ourdesk.atlassian.net which is the correct behavior. 
  7. If sent to jira@ourdesk.atlassian.net the email goes nowhere, never arrives in the queue, goes into a black-hole. 

TEst - ignore.png

In response to the the three dot question see the screenshot below. 

EMail.png

-Mike

Hello Mike

i looked into the email headers and found out that:

From: Michael Roth <jira@docudesk.atlassian.net>

Reply-To: ser@docudesk.atlassian.net

To: client@email.com

so here it looks okay - but! Reply goes to jira@ ... and the customer gets no notification, the agent gehts no notifications, the most important function does not work for us.

The Client is a Outlook 365 Web E-Mail.

I am posting a Screenshot.reply.png

ah, and i dont have the "Configure Request Types" in this menu, this item is missing, maybe becose i just use the default email request type or i only have one.

Hi @Michael Roth 

Maybe you are not Site administrator, which is why you can't see three dots. I would suggest you disable the email and start again, but I don't think you can (if you can't see the three dots). 

Maybe try and send a request from a GMAIL account and see if you can replicate the issue. 

Do you now accept requests via Customer Portal as well? 

I can't think of anything else for now. Sorry. 

-Mike

Hi Mike

it works from office-desktop client but it just does not work from office 365 web client (newest office 365 available).

So i think, thats a Problem with microsoft but still it does not solve my problem.

Can we change the global mail adress from jira@... to support@ somehow??

Best Regards
Michael

Hi @Michael Roth 

That side of the things, I am not sure of.

The best thing to do is probably raise a request with Altassian, who will be able to advise you.

In Jira Settings there is a whole section on Email, servers, POP/SMTP etc, but it would be wrong for me to advise you to check there, when I don't know what changes here would mean to your whole setup. 

 

Best regards,

-Mike

i raised a request, the support from Altassian is ultra slow - so i will wait ....

did Atlassian support says anything, hitting the same issue for 365 web users only

Hi @Giancarlo Bisceglia @Michael Roth 

Check out this post reply from @Keith Schlotzhauer - he managed to resolve his issue with O365. 

 

-Mike

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Jira Service Management

Announcing Jira Service Management!

Hello there Cloud Community members! Today, we’re thrilled to announce Jira Service Management, the next generation of Jira Service Desk. Jira Service Management touts advancements in IT service ...

2,226 views 28 39
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you