Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Unable to show attachments - After upgrade

We just upgraded our local server edition of Jira from 8.14.0   to  8.15.0  . After this, It is not possible to view attachments ( .jpg ,  .PNG )  on most of our service desk cases. We have tried on several PC's and tried Edge, Chrome, IE .  
I did some research and tried some of the suggestions provided on the community pages. 

It might be a bug in the new version, maybe....

Any ideas?

2 answers

Hi Reza,

Can you include the error produced when you try to access an attachment from the UI and tell us which upgrade method you used? It is likely that permissions on those files are wrong or the attachments are not where the app expects. Cheers!

Hi
Thank you.  I downloaded the Jira-Core_8.15.0-X64.exe  from the Atlassian homepage and ran it on the server. This is the method, I have used ( many times) in the past to upgrade. There were no error messages and such during the installation/upgrade. Afterwards, everything is in order, except the attachments in our service desk case.

Here is a screenshot :ServDesk_error.jpg

 

Clicking the link to the picture, give us the ""Ouch! We can't load the image."

ServDesk_error2.jpg

Hi Reza,

Can you go to Admin > System > System Information and find where the app thinks your Jira Home directory is? Compare this with the actual location of the attachments. Also, have you reviewed permissions on the attachment directory / files? Cheers!

Hi

Thank you. Following is the path in JIRA, and the actual folder structure on the server. DF, DS (Development SCRUM), IS (Infrastructure SCRUM) and SUP ( Support Desk ) are our projects in Jira. 

 Jira_Error01.jpg

 

It seems to be correct according to the JIRA documentation. 

Furthermore, the actual files are located here :

Jira_Error02.jpg

I am a bit unsure about the permissions. I am starting the JIRA service by "NETWORK Service".  This "user" and the admin user which I used to install the program, has Full control NTFS permissions on all the JIRA folders. I have double-checked that all the permission are inherited. The permissions are like this

 

Jira_Error03.jpg

0 votes

@Reza Eram

Another user is seeing this as an issue as well. There's another question in the community about it. Based on the fact that two users are seeing it in the same circumstance, I would immediately raise a support request with Atlassian about it!

Thank you, Kian. I'll keep an eye on the other case as well, as it seems to be the same error as ours.

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
SERVER
VERSION
8.15.0
TAGS
Community showcase
Published in Jira Service Management

Why upgrade to Jira Service Management Premium?

We often have questions from folks using Jira Service Management about the benefits to using Premium. Check out this video to learn how you can unlock even more value in our Premium plan.  &nb...

209 views 1 6
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you