Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Jira Service Management - MSoffice,pdf etc. and img files are not displayed

Hi,

I need your help 

Today I upgraded 8.14 to 8.15 and switched to HTTPS
but I can no longer see the files I added.
when I want to see image files errors is ;

"Ouch! We can't load the image.

/secure/attachment/10602/SupportTiers.jpg"

when I want to see office document, pdf, etc files errors are;

<!DOCTYPE html><html lang="en"><head><meta charset="utf-8"><meta http-equiv="X-UA-Compatible" content="IE=edge"><title>Oops, you&#39;ve found a dead link. - JIRA</title><script type="text/javascript">contextPath = "";</script><link type='text/css' rel='stylesheet' href='/static-assets/metal-all.css' media='all'><script src='/static-assets/jquery-min.js'></script><script src='/static-assets/metal-all.js'></script><meta name="decorator" content="none" /></head><body class=" error-page error404"><script type="text/javascript">document.body.className += " js-enabled";</script><div id="page"><header id="header" role="banner" aria-label="Site"></header><div id="content"><div class="aui-page-panel" ><div class="aui-page-panel-inner"><main role="main" id="main" class="aui-page-panel-content lowerContent" ><div id="error-state"><span class="error-type"></span><h1>Oops, you&#39;ve found a dead link.</h1><ul><li>Go back to the <a href="javascript&colon;window.history.back()">previous page</a></li><li>Go to the <a href="/secure/MyJiraHome.jspa">Home Page</a></li></ul></div></main></div></div></div><footer id="footer" role="contentinfo"><section class="footer-body"><ul class="atlassian-footer">
    <li>
        Atlassian Jira <a class="seo-link" rel="nofollow" href="https://www.atlassian.com/software/jira">Project Management Software</a>
                                            <span id="footer-build-information">(v8.15.0#815001-<span title='9cd993cd5d44d1112926026f768b18ff3cb391a3' data-commit-id='9cd993cd5d44d1112926026f768b18ff3cb391a3}'>sha1:9cd993c</span>)</span>
    </li>
    <li>
        <a id="about-link" rel="nofollow" href="/secure/AboutPage.jspa/secure/AboutPage.jspa">About Jira</a>
    </li>
    <li>
        <a id="footer-report-problem-link" rel="nofollow" href="/secure/CreateIssue!default.jspa">Report a problem</a>
    </li>
</ul>
    <p class="atlassian-footer">
        <span class="licensemessage">
            
        </span>
    </p>
<div id="footer-logo"><a href="http://www.atlassian.com/" rel="nofollow">Atlassian</a></div></section></footer></div></body></html>

Thanx

1 answer

1 accepted

0 votes
Answer accepted

@Ali Aydın,


I see this if the files were removed from my file system and I try and access them. When you upgraded, how did you do it? Does everything else appear to be working fine? Is it all attachments, or just select ones?


Thanks,

Kian

After uploading files, I cannot access them again. It is the same if I created ticket on the portal and application. I made the upgrade by downloading the new package. The interesting thing is that the place where the file is located appears as secure / attachment in the url, but I couldn't find such a folder

@Ali Aydın, that's not how the attachments are packaged on the backend. They are located in the directory <jira-home> /data/attachments. Are you saying that you've tried to upload new attachments and after you upload a new attachment you can't access it?

Thanks,

Kian

After adding a new attachment, I cannot access it and it happened after the upgrade. Do you have any suggestions for solving this problem? If not, I will necessarily downgrade it.

@Ali Aydın

I don't see any bugs logged with Atlassian indicating that this is an issue. You've either found a critical bug, or something went wrong with the upgrade itself.

If you can upload, but not download, can you validate that the files are actually making it into the expected file location?

You can use this guide to figure out where the attachments should be.


Also, did you perform a test upgrade? If so, did you see these issues there as well?

Thanks,

Kian

@Ali Aydın, just to follow up with you on this, another user just asked the same question as you in the same circumstance. I would alert Atlassian to this issue right away using a support request. For an immediate fix, it might make sense to try downgrading.

Thank you Kian

Hi @Kian Stack Mumo Systems 

I think they solved this problem in the Cloud version?

When they solved in the Server version? Do you have any idea?

Regards

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
SERVER
VERSION
8.15
TAGS
Community showcase
Published in Jira Service Management

Why upgrade to Jira Service Management Premium?

We often have questions from folks using Jira Service Management about the benefits to using Premium. Check out this video to learn how you can unlock even more value in our Premium plan.  &nb...

157 views 0 4
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you