Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,465,490
Community Members
 
Community Events
176
Community Groups

The option for field does not exist, when it clearly does

I have a field named Drop that I'm using in my data analysis and I use JQL to filter its values. When I want to filter the value "none", i get the error The option 'none' for field 'Drop' does not exist.

Screenshot 2022-07-07 144759.png

 

Screenshot 2022-07-07 145008.png

This was also reported here but the workaround found by the reporter doesn't work in my case.

3 answers

Hi @Ancau_ Adelina and welcome to Community!

Can you try using the autocomplete when typing your JQL? What is suggested when you type the following:

 "Drop" =

Can you also try with the below JQL?

"Drop" is empty

Autocomplete suggests other valid options, but not "none".

Using "Drop" is empty gives me the tickets that don't have the Drop field.

Another possibility could be that the value "none" is actually "none " with a space at the end or something like that. What type of custom field is Drop? Is it a dropdown, a cascading select list, a text field?

Dirk Ronsmans Community Leader Jul 07, 2022

Maybe even an Insight custom field? :)

if you can I’d check the configuration of the field. Making sure that the context of that value is actually valid for what you are searching too ..

if you can screenshot the config even better :)

@Manon Soubies-Camy _Modus Create_I've tried adding spaces but I still get the error.

Drop is a dropdown.

Apparently "none" is actually "none (not available)" and there is also a "None" option. However these can't be accessed through the JQL either.

Screenshot 2022-07-08 121911.png

Screenshot 2022-07-08 093425.pngScreenshot 2022-07-08 093450.png

@Dirk RonsmansI think this is the field configuration.

Screenshot 2022-07-08 122743.png

The other (valid) values for the Drop field contain letters, numbers and even symbols (dots and dashes), so I don't think type mismatch could be an issue.

Hi @Ancau_ Adelina, does it work if you remove the "project = xxx AND" from your JQL query?

@Dirk Ronsmans may be right when talking about the field context. Maybe this value "none" is not available in that project.

@Manon Soubies-Camy _Modus Create_it doesn't work if i remove "project = xxx AND".

I don't know how the value could be not available in the project, since I can clearly see tickets having it.

Screenshot 2022-07-07 144759.png

1 vote
Dirk Ronsmans Community Leader Jul 07, 2022

Hey @Ancau_ Adelina ,

Is it actually "none" in the configuration? Cause in Jira in a lot of things when something (like a single select field) has the value "None" it's actually an empty field.

You could try "Drop" IS EMPTY and see if that works?

I'm not sure about the configuration but for "none" it is definitely not an empty field. When I use "Drop" IS EMPTY I get the ones that don't have the Drop field, not the ones that have "none" as value of the Drop field.

Dirk Ronsmans Community Leader Jul 07, 2022

i'm going with my next gut feeling here, any chance you have multiple fields with the name "Drop"? 

No, just this one.

0 votes

I do not know if you are still looking for an answer on this one @Ancau_ Adelina

However, it has happened to me in the past that the filter would not work when I was using (") for the value and once I change to (') it would. So might worth giving it a go like that (= 'none')

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events