Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

ServiceDesk seems licensed but not installed

Hello,

I have updated my JIRA instance to version 8.13.2 and I am seeing the attached.

As shown my Service Desk is licensed (until the end of the year) but not currently installed! How is that possible? What can I do to get back to normal operation?

I have tried to press the "Install"  button as indicated but I am getting an unexpected error. Which log should I refer to in order to see something useful because I haven't found anything useful at "catalina.out", "atlassian-jira.log" and "atlassian-servicedesk.log"

The strange thing is that my portals seem to be available, so I don't know if this is a bug or what...

All suggestions are welcome.

Best regards,

G.SD_Error.JPG

2 answers

1 accepted

The solution to this problem if anyone reaches this thread in the future is to verify that the "ServiceDesk" application hasn't been disabled.

 

It seems that during the upgrade for an unknown reason (bug???) the plugin was set as disabled...

One should stop its JIRA instance and check the DB using "

select * from pluginstate where pluginenabled = 'false';

 

If "com.atlassian.servicedesk.application" is shown there it should be enabled using the following:

UPDATE pluginstate SET pluginenabled='true' where pluginkey='com.atlassian.servicedesk.application';

 

Then restart your JIRA instance and you should be all right!

 

Kudos to the original poster @somethingblue and his initial post at: https://community.atlassian.com/t5/Jira-questions/Service-Desk-Application-Will-not-Install-after-JIRA-Core/qaq-p/619167

 

That concludes a 4-day search...Wish I had found the solution earlier...

 

Regards,

 

G.

1 vote

I think it is a bit of a bug, yes.

The atlassian-jira.log file is the one that should be recording what happens when you try to install an app (catalina.out is the Tomcat log, not Jira, and the stuff in the servicedesk.log is generated by using servicedesk, not the basics of Jira)

The good news is that if your portals are working, then that implies Jira Service Desk is installed and active.  If it were not installed, your portals would not be there at all.

The bad news is that I am not sure how you could get a "JSD not installed" message from a system that clearly does have it installed (because it is serving up portals)

Ideally, I'd fire up a command line, log into the server, and go "tail -f atlassian-jira.log".  Then pop a browser window and go to the screen in your screenshot, and hit install, then swap to the terminal window and read what happens.

Even though that might not tell you much, the gumpf that goes into the log at that point is the "unexpected error" and is worth having if we remain stuck and want to reach for direct Atlassian support.

Hi Nic,

unfortunately I have done this a numerous times without anything useful in the logs as written before...

Here is what I am getting in the "/var/atlassian/application-data/jira/log/atlassian-jira.log" file after I press install and when the error is shown on the web interface:

2020-12-05 11:45:09,836+0200 UpmAsynchronousTaskManager:thread-3 INFO $username 701x180x1 13vee72 xxx.xxx.xxx.xxx,yyy.yyy.yyy.yyy /rest/plugins/1.0/ [c.a.plugin.loaders.ScanningPluginLoader] No plugins found to be installed
2020-12-05 11:45:09,902+0200 UpmAsynchronousTaskManager:thread-3 INFO $username 701x180x1 13vee72 xxx.xxx.xxx.xxx,yyy.yyy.yyy.yyy /rest/plugins/1.0/ [c.a.plugin.manager.DefaultPluginManager] Updating plugin 'com.atlassian.servicedesk.application' from version '4.13.2' to version '4.13.2'
2020-12-05 11:45:09,910+0200 UpmAsynchronousTaskManager:thread-3 INFO $username 701x180x1 13vee72 xxx.xxx.xxx.xxx,yyy.yyy.yyy.yyy /rest/plugins/1.0/ [c.a.plugin.loaders.ScanningPluginLoader] Removed plugin 'com.atlassian.servicedesk.application'
2020-12-05 11:45:10,158+0200 UpmScheduler:thread-2 WARN $username [c.a.upm.pac.PacClientImpl] The request to check for app updates may take longer than expected because 198 apps are installed that could have updates. This may impact the performance of loading the Manage Apps page.

The same thing appears when I try to install it over above it...

You can find an excerpt of the log where you can see all messages from the time I pressed "install" until the error appearance on the web interface HERE.

Most probably all info in there is irrelevant in it since they are based on periodic runners except the one I have pasted above but just in case you can review it... One side note is that I have masqueraded the "username" and the "IP addresses".

 

I was thinking of either updating to 8.14.0 or deleting the license to see if this would change anything but I don't want to mess everything up especially now that I have a working (seems to be) system.

What do you think?

Any ideas if I have to reach Atlassian to submit a bug or should they pick it up from here?

 

Best regards,

 

G.

I do think you should raise a support request - this behaviour is  not right.  Displaying an application as not installed when it's clearly working can't be good.

Https://support.atlassian.com/contact is the starting place.

Hi!

 

Thanks for the feedback...I have already tried that but it seems that I am stack here :-(

I have a starter license hence I am not entitled to Atlassian support :-(Atlassian.JPG

I did manage to contact Atlassian but my request went to billing and licensing team.... this is where my request ended since it seems that there is no way to properly report a bug if you are on a starter license! Ridiculous ....

Anyway the feedback I got was the following: “...This is out of my scope of support and to better assist and answer your queries regarding your technical issues, you would need to seek assistance from Community Support where we have Atlassian partners, experts, and champions to assist you.

As Community Support is the only channel available for our Free and Starter license users, we make sure to pay special attention to getting to these requests. ...”.

Hence I have no other option but to wait....so fingers crossed that until then all will continue to function without having a problem.

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
SERVER
VERSION
8.13.2
TAGS
Community showcase
Published in Jira Service Management

Why upgrade to Jira Service Management Premium?

We often have questions from folks using Jira Service Management about the benefits to using Premium. Check out this video to learn how you can unlock even more value in our Premium plan.  &nb...

170 views 0 4
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you