Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

SLA Display Error

Hi 

Since two weeks ago, our SLAs for a certain issue type isn't working.  When I had  a look in the SLA that issue type wasn't there so I added it back but it still doesnt appear. there are blanks for some issues for that particular issue type. 

 

Then I tried creating a separate SLA for that issue type it appears like this 

So please give me some suggestions on how to fix this. 

 

Thanks

Aamina

2021-12-15_13-30-57.jpg

3 answers

@Aamina Reihana 

 

To give you a more direct answer, we would need to see how your SLA rules are set up, what JQLs you use, etc.

But if one of the SLA's at some point you're using something like:

START: Status (Open, Awaiting response, Closed"

JQL: issuetype = Story and Status = "Waiting for response".

So this should be a separate SLA to start counting

If you can review the SLAs or show the SLA and JQL that you are having problems, we may be able to help you better.

Hi There

Thank you for your reply. So we have two SLAs for this project. One is "Time to first response" and the other is "Time to resolution. 

Here is the "Time to first response" SLA and the issue type that it's not populating for is "Operations Request" . Snag_3c56ad9.png

This is the SLA for "Time to Resolution" SLA and the conditions. 

Snag_3c55974.png

Snag_3c5773d.png

I have deleted all the test SLA's I created as they didnt work either. 

This is how the queue looks now. I have highlighted the empty fields for the operations request issue type. 

Snag_3ca1a7f.pngSnag_3ca5f38.png

Hey, @Aamina Reihana 

I replicated the scenario you are using in the 2h SLA.

The error is in the OR condition of your JQL. For SLA's, when it comes to including more than one value for the same field, we use the IN function and not the OR.
Try using the following JQL in your 2h SLA:

issuetype in ("Service Desk", "Awareness Notes", "ECN", "DV/PV", "Operations Request")

Each issuetype is separated by a quote(") and a comma(,)

I believe that for the first case this will work. Then just replicate the same "IN" condition for the other SLA's.

@Aamina Reihana 

 

For the other SLAs of 8h, 16h, 30h and 80h use the same IN condition.

For example the 80h:

issuetype in ("Service Desk", "Awareness Notes", "ECN", "DV/PV", "Operations Request") AND priority = P4/Minor

Just apply this "IN" setting to the others and I believe it will work.

If this doesn't work, come back here and we'll continue to help you.

HI Fernando

Thanks for that and its partially working. 

I have made those changes to the SLAs so  now they look like this.  This is Time to resolution and I tried putting quotes around ECN but it kept resetting probably because its one word.  The time to resolution is working but not the time to first response. Snag_18b00078.png

This is to time to first responseSnag_18b3e9ef.png

There are two fields for time to first response that aren't populated at all and these are for Operations Request issue type. 

 

Thanks

Aamina

Hi Fernando

Thanks for continuously helping me with this. 

We currently have conditions in place when starting and stopping the SLAs. 

Here is a screenshot. Snag_1d8d5c8b.png

Does the above look ok? The part that Im confused about it is that the conditions and SLAs worked fine before. No idea what stopped it from working. 

 

Thanks

Aamina

@Aamina Reihana 

 

Seeing this way, the settings seem correct.
I believe that there is some other SLA with similar settings preventing the visualization of this one.

We can keep reviewing to help you, plus you can also open a support ticket at Atlassian via the link: https://support.atlassian.com/contact/#/

If it's something from the environment, the team can correct it.

But I would recommend that you review the other SLA's to ensure that none of them have a similar JQL, with the same conditions and that may be preventing you from viewing this one.

 

Hey, @Aamina Reihana 

Happy to know you managed to solve one of the topics.

Under Star to counting conditions for the First Response SLA, what is included?

I exactly replicated your rule in my environment and got the following result:

Time to first response:

 

Time to first response.PNG

Time to resolution:

Time to resolution.PNG

 

See that I filled in the priority as "Medium" highlighted, because that's what I used in the following test:

SLA TEST.PNG

 

Perhaps the detail you are needing to have is the "Conditions" to start counting and/or pausing.

Does the Time to first response SLA appear for all, some or no issuetypes?

See another test with the Issuetype "Operations Request" and the highest priority.

The value for the time to resolution SLA changed as inserted in the previous JQL, but the time to first response value remained with 2h, as configured in its due SLA.

SLA TEST 2.PNG

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
PRODUCT PLAN
STANDARD
PERMISSIONS LEVEL
Site Admin
TAGS
Community showcase
Published in Jira Service Management

Next level incident management in Jira Service Management

Hello Atlassian Community! We’re thrilled to announce some exciting changes to incident management in Jira Service Management Cloud, in order to give your teams extra muscle during incidents, and ...

1,474 views 20 12
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you