Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Resolved date not allocated to transitioned calls - Automation for Jira

leandi.mollentze@hensoldt.net February 2, 2021

Hi everyone!

We are currently using automation for jira to transition issues that have been in a waiting for customer state for 14 days to resolved. This works perfectly except that a resolution date is not assigned to the issue.

This is skewing our reporting data.

When we do this manually (transition the issues ourselves) the date is assigned. It is only when it is handled through the automation that no date is assigned.

Why is this and how can we resolve it?

Automation Rule.JPG

2 answers

0 votes
Brett Palmer December 1, 2023

You need to have the transition post-function set the resolution then that transition will update the resolution date field. 

0 votes
Jack Brickey
Community Leader
Community Leader
Community Leaders are connectors, ambassadors, and mentors. On the online community, they serve as thought leaders, product experts, and moderators.
February 2, 2021

If you are setting the Resolution then there should be a resolution date. Check to ensure the resolution is in fact being set.

koelofse February 2, 2021

Nope - no date is being set. See the extract below - resolution is set. No date.

Resolution Date.JPG

Jack Brickey
Community Leader
Community Leader
Community Leaders are connectors, ambassadors, and mentors. On the online community, they serve as thought leaders, product experts, and moderators.
February 2, 2021

Odd for sure. I assume if you manually transition the date is set?

leandi.mollentze@hensoldt.net February 2, 2021

That is correct which is what I am currently having to do to rectify the skewed data. Problem is we cannot keep using this automation if it is going to keep doing this in future.

Jack Brickey
Community Leader
Community Leader
Community Leaders are connectors, ambassadors, and mentors. On the online community, they serve as thought leaders, product experts, and moderators.
February 2, 2021

I would suggest reach out to support directly as this seems like a bug. I’m on cloud so unable to test.

leandi.mollentze@hensoldt.net February 2, 2021

Thanks! I will contact them :)

Bernd Gurn September 15, 2023

Hi, did you get an answer? If yes, what was it? It seems that we have the same issue (https://community.atlassian.com/t5/Jira-Service-Management/Resolved-date-time-not-used-by-automation-rule/qaq-p/2478518#U2478521) . And it looks like to me a bug/defect to be.

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
SERVER
TAGS
AUG Leaders

Atlassian Community Events