Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Linking to a heading on a page does not work

Joseph Narai March 13, 2024

I have a confluence space linked as a knowledge base to JIRA Customer Service Desk.

I'm trying to add a link in one page, to a heading on another page.

It works as a confluence user, but when a customer logs in to service desk, the link is broken with:

 

Not Found

We are having trouble finding that. Check the details and try again.

 

I can link to the page itself, just not to an anchor or heading.

2 answers

1 accepted

0 votes
Answer accepted
Joseph Narai March 27, 2024

I found the issue, funnily enough, just after I upgraded to the Standard Plan and opened a support ticket. I tried it again, and it all worked! So, our Confluence plan had downgraded to Free, where the permissions are not available to work seamlessly with the Service Desk!

So, the answer is you need to be at least on the Standard Plan to enable links to headings in articles to work correctly.

Thanks again to Brant for all your help, much appreciated.

Brant Schroeder
Community Leader
Community Leader
Community Leaders are connectors, ambassadors, and mentors. On the online community, they serve as thought leaders, product experts, and moderators.
March 27, 2024

Joseph that is not the answer as I tested on a free and paid plan and both worked.  My guess is it was something to do with the permissions available in Confluence on the paid plan.  Was the space that contains your knowledge base setup as a public space prior to downgrading to the free plan?

Joseph Narai March 27, 2024

I'm not sure then. The Atlassian support engineer confirmed that I have to remain on the standard plan for this to work - I guess I could try and downgrade again and see if it breaks again?

All I know is that it's never worked from when I set the space up, and when I started the Standard Trial yesterday it started working. I originally set the space up via the Knowledge Base section of the JIRA Customer Service Desk, and just used their recommended default permissions.

I did try checking and changing a number of permissions in Confluence, nothing worked.

All I know is I followed the advice of their support engineer and started the Confluence Standard Trial, and then when I went to set up the test pages to show them the issue, it all just worked. So, unless they tweaked something without telling me, it just resolved when I upgraded as I didn't change anything else.

 


This was the reply from the Atlassian support engineer:

Thank you for highlighting the subscription changes for me. Regarding the Confluence Free plan, the option to modify space or page permissions is not available, which explains why the links to other knowledge base articles didn't function as expected. It's understandable that without granular control over access permissions, certain functionalities may be limited.

Therefore, maintaining the Standard plan would be necessary if you require that level of control over space and page permissions.

Brant Schroeder
Community Leader
Community Leader
Community Leaders are connectors, ambassadors, and mentors. On the online community, they serve as thought leaders, product experts, and moderators.
March 28, 2024

@Joseph Narai Atlassian support confirmed what I stated.  You modified the space / page permissions.  If you removed those changes then the kb would work as expected on the free plan. 😀

Joseph Narai March 28, 2024

I only tried changing permissions because it didn't work.

So that doesn't make sense to me. But sure, I'll accept that as the answer.

Thanks again.

Joseph Narai April 1, 2024

@Brant Schroeder So I've just put my confluence account back to Free and it does appear the issue is no longer happening. So, after all this, I don't have a solution, it just miraculously started working after I upgraded to Standard and kept working after I put it back to Free.

I don't have a real answer as to how to resolve this if someone else has it happen to them.

0 votes
Brant Schroeder
Community Leader
Community Leader
Community Leaders are connectors, ambassadors, and mentors. On the online community, they serve as thought leaders, product experts, and moderators.
March 13, 2024

@Joseph Narai Welcome to the Atlassian community

Are they clicking the link in the service desk and it is then breaking?  Can you share a screenshot of what you have setup and the error?

Joseph Narai March 17, 2024

Correct they are clicking the link in the service desk and it breaks.

Steps to reproduce.

  1. Go to destination article.
  2. Find the heading and click on the copy link button that comes up on the right side of the headingScreenshot 2024-03-18 124449.png
  3. Go to the source article.
  4. Paste the link in the source article.
  5. Update the page.
  6. Now if you are logged in as a confluence user, clicking on the link in the source article takes you to the destination page and heading.
  7. If you are logged in as a service desk customer that has permissions to view the pages, the link does NOT work
    Screenshot 2024-03-18 125128.png
  8. This is the error that comes up.
    Screenshot 2024-03-18 125243.png
Joseph Narai March 17, 2024

Oh, and one important point. If I just link to the page itself, it works fine. So the customer service desk customer has permission to view the page... but trying to link to a heading on that same page breaks the connection...

I can see that the url is being mangled, and whatever is in that url seems to be what's preventing the link to work.

Brant Schroeder
Community Leader
Community Leader
Community Leaders are connectors, ambassadors, and mentors. On the online community, they serve as thought leaders, product experts, and moderators.
March 17, 2024

@Joseph Narai I must be missing something.  When I click the copy link and then past it into the article and then click it while logged in as a customer is till resolves to my Confluence article.   I am able to see the proper link when it loads in the service desk.  Mine shows up as https://xxxxx.atlassian.net/plugins/servlet/servicedesk/customer/confluence/shim/x/0nCmXT when I hover over it.  

Joseph Narai March 17, 2024

So just clarifying you've logged into an incognito window and logged in as your customer and it does resolve?

And your confluence page is private to your customer service desk? I imagine if I made the confluence space public, it would work ok.

I'm probably the one that's missing something, I just don't know what.

This is my link setting.Screenshot 2024-03-18 154832.png

 

Brant Schroeder
Community Leader
Community Leader
Community Leaders are connectors, ambassadors, and mentors. On the online community, they serve as thought leaders, product experts, and moderators.
March 18, 2024

@Joseph Narai My confluence space is private.  I logged into JSM as a customer in a different browser and did not have an issue.

Joseph Narai March 25, 2024

Thanks for clarifying.

I don't know what else to do, I guess I'll have to upgrade to a standard plan to get some support from Atlassian?

I've just reproduced it on a single page:

 

Screenshot 2024-03-25 204720.png

So, if you click on heading 1 or or 2 at the top, nothing happens (it can't scroll anywhere as both headings are within view) ...

But if I click on either link in the text, which I've just copied the links from the Headings above... it opens a new tab and asks my customer to log into confluence with an Atlassian account!

I'm happy to give customer access to anyone who might have an idea and wants to check it ... I can't make the confluence space or knowledge base public, as I'm assuming it will work ok if I do that, but it's not a public knowledge base....

Any other suggestions will be greatly appreciated, not sure what else I can do... I have had to literally remove all internal links in my documents, as I've had customers click on them and get prompted to create an Atlassian account!

Thanks in advance for any and all help - I'm very confused as to what I could be doing wrong!

 

Brant Schroeder
Community Leader
Community Leader
Community Leaders are connectors, ambassadors, and mentors. On the online community, they serve as thought leaders, product experts, and moderators.
March 25, 2024

@Joseph Narai Thanks for the follow-up.  I was able to recreate the issue that you are having based on what you shared above.  There is a simple fix.  When you add the link is all you have to add is the end of the URL, the # piece.  This is all that is needed to access the link on the page.

Example: 

Link that you copied: https://XXXXXXXXX.atlassian.net/wiki/spaces/XXXX/pages/XXXXXXXXXX/Link+Test+2#This-is-header-3

What you should add to from the link so it will work in the KB: #This-is-header-3

Joseph Narai March 25, 2024

Hi Brant,

    Thank you for that - that has allowed me to re add the internal links in my articles again.

    I still have the issue where it wants me to log in if I try and cross link to a heading. One of the Atlassian support engineers suggested I need to enable anonymous login on the confluence side to fix this. (which I can only do on the standard plan). 

    Can you tell me if you have enabled anonymous login on your confluence instance? You were saying you couldn't reproduce my original issue.

    Do you know if anonymous log in would allow anyone to see the confluence pages, I'm assuming not, as I would need to make it public for that?

    Once again, thank you for the assistance so far. Much apprecaited!

 

Brant Schroeder
Community Leader
Community Leader
Community Leaders are connectors, ambassadors, and mentors. On the online community, they serve as thought leaders, product experts, and moderators.
March 27, 2024

@Joseph Narai I was able to do a little testing and when cross-linking pages I was never able to run into any issue if I used the link button in the Confluence editor.  If I copied the URL from the URL or Link and I added it to a page using this button it always worked in the JSM portal.   All of those links on one page properly loaded to the other page within JSM.  I was also able to hover over the links and see that it is correct as well.  For instance if I had the following link in Confluence and it showed as such in Confluence the actual link was different in JSM even though it link text showed what it was in Confluence.

Confluence Link - https://XXXXXX.atlassian.net/wiki/spaces/XXXXXXXX/pages/XXXXXXXXXX/Link+Test+2#This-is-header-3

JSM Link on Hover or Click - https://XXXXX.atlassian.net/plugins/servlet/servicedesk/customer/confluence/shim/spaces/XXXXX/pages/XXXXXXXXXX/Link+Test+2#This-is-header-3

 

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
PRODUCT PLAN
STANDARD
PERMISSIONS LEVEL
Site Admin
TAGS
AUG Leaders

Atlassian Community Events