Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,365,215
Community Members
 
Community Events
168
Community Groups

Jira Automation "Only include issues that have changed since the last time this rule executed" miss

Hi

 

Some of my Automation rules are "doing nothing" because of this:

ScreenHunter 940.png

I can remember that tick box.. but can't find it.

I can see the sentence, but there is no box to tick or untick.

What I'm missing here?

 

ScreenHunter 942.png

4 answers

Hi , we have the same issue. Have you found any solution to this? 

Hi Antreas,

Since my latest post, we've upgraded our Jira Server instance to v8.20.x (LTS release). With that upgrade the checkboxes finally returned. :)

Since then we've had other issues with 'Automation', the latest being an Error 500 when trying to access the 'Automation' GUI. However, this problem could also be resolved by an upgrade of the 'Automation' add-on. We are now currently on v8.0.0, and so far everything is working smoothly (fingers crossed).

In reply to your question, I would assume that an upgrade of your Jira instance should do the trick. Of course, this might depend on your specific configuration. Also, I cannot entirely rule out that there might also have been some interdependency with other add-ons (like e.g. ScriptRunner). Since we generally update all our add-ons in one go, it's difficult to tell which particular update caused the checkboxes to return. I'm just glad they did! ;)

I can confirm the issue (Jira Server v8.5.8 Long Term Support Release + Automation for Jira Server add-on v7.2.8). Having the same problem where some of the check boxes are no longer visible / not displayed anymore. Definitely NOT a browser-related issue either, as I have already tried with different browsers (on Mac and PC). Same problem everywhere.

This is a rather annoying bug, too, as it makes it extremely difficult to see if an option is currently enabled or disabled – trial & error being the only way to tell.

A fast fix would be very much appreciated!

UPDATE:

Just read on a different thread that the issue is probably related to running a specific version of Adapatavist Script Runner:

https://community.atlassian.com/t5/Jira-Software-questions/Automation-Only-include-issues-that-have-changed-since-the-last/qaq-p/1609376

Downgrade to an earlier version of Script Runner seems to be a viable temporary solution until a fixed version of Script Runner becomes available.

UPDATE:

Unfortunately, updating both ScriptRunner and Automation for Jira (A4J) to their latest versions (6.23.0 and 7.2.8 respectively) did NOT do the trick, yet.

The issue with the "invisible" check boxes persists. 

0 votes
Daniel Ebers Community Leader Feb 12, 2021

Hi @betigolo 

I see a second check box missing on your screen. At least it should show greyed out when not possible to select in a specific condition/state - I have never seen it is missing, though.

Out of curiosity, are there more check boxes missing apart from they two? I am wondering if it could be a browser related issue.

Have you installed latest updates for Automation and tried to disable/re-enable the App?

Regards,
Daniel

0 votes

This option applies for Scheduled rules with JQL rule as shown below

 

F84E84D9-8289-4150-A53A-C15A69D0C102.jpeg

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events