Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Automation - 'Only include issues that have changed since the last time this rule executed' checkbox

Hi

 

Some of my automated rules are doing nothing. The log says:

ScreenHunter 940.png

 

I can remember this option, but can't find the box to deselect:

Where is the box?

What I'm doing wrong here?

 

ScreenHunter 942.png

Humberto

 

7 answers

I'm investigating this. A workaround for the moment: clicking on the text associated with a checkbox is typically sufficient to toggle the checkbox. Try clicking the text then saving the rule. You'll know if worked if the rule starts executing on all relevant issues.

Edit: didn't realise this was for A4J Server. I'll check with that team to see if they have news.

Having the exact same issue.

  • Jira 8.5.9
  • A4J 7.26

I can confirm that its still working in our second instance, with the same Jira version but A4J 7.1.16. 

Thanks for sharing

Like John Funk likes this
0 votes
Jack Community Leader Feb 11, 2021

This seems to be a duplicate and yet under a different member - Jira-Automation-Only-include-issues-that-have-changed-since... 

Yes, it's duplicated.

Now I can understand why could not see/find the first one.

Humberto

Jack Community Leader Feb 11, 2021

can you try to add a new rule just as a test to see if the checkbox is there?

Already done. Same issue. the box is not there.

Jack Community Leader Feb 11, 2021

thanks for the update. seems like it is time to reach out to the Atlassian for support 

Like # people like this
Jack Community Leader Feb 11, 2021

p.s. I have inquired thru my other connections seeking other Server A4J users to see if anyone is experiencing this. Maybe they will chime in here FWIW. 

Like Dave Liao likes this
Hana Kučerová Community Leader Feb 11, 2021

Hi @Humberto Gomes ,

I've just tested it using AfJ 7.2.6 and Jira Software 8.8.0 and I was able to use the checkbox. So it seems to me it is not connected to the latest version. As the others said - it will be the best to reach out to the Atlassian, it is really strange.

Hi...  Did you notice that the radio buttons immediately above, for other options, also appear to be missing on that view?

0 votes
Hana Kučerová Community Leader Feb 11, 2021

Hi @Humberto Gomes ,

yes, I think this is the right place. The checkbox is missing, but I believe it should be there.

scheduled.png

If you try to delete the trigger and add it again, does the checkbox appear?

Jack Community Leader Feb 11, 2021

Or try adding a new rule

New Rule:

Same Problem

 

Already done:

Browsers: Chrome, Edge

All with clear Cache.

 

No results.ScreenHunter 943.png

0 votes
John Funk Community Leader Feb 11, 2021

Hola Humberto - it's probably not there because you are not a Jira Administrator and the rule is a multi-project or global rule. You can get an Administrator to update it to uncheck the box,

Hi,

I'm the Jira Administrator.

John Funk Community Leader Feb 11, 2021

Are you using the Free Lite version or the Paid Version? 

John Funk Community Leader Feb 11, 2021

I would definitely open a support ticket with Atlassian.

Please post the resolution back here so we can close this one out. 

Like # people like this

What we know at this moment:

 

  • I'm the JIRA admin. (same problem)
  • 2 different browsers tested. (same problem)
  • Both with Cache cleared. (same problem)
  • Creating a new rule  (same problem)
  • Asked to be done by other Jira admin (new laptop, network, browsers...) (same problem)

 

Versions:

  • Automation for JIRA version: 7.2.6
  • Jira Server version: 8.5.3

 

What next?

 

It's a bug from this version?

 

Humberto

Answer from Atlassian Support:

 

try the below options:

  • Disable and enable the Automation for Jira to check if this resolves the issue
  • Clear plugin cache
  1. Stop the JIRA instance.
  2. Delete JIRA_HOME/plugins/. bundled-plugins and JIRA_HOME/plugins/. ...
  3. Restart JIRA.

Update:

 

  • Disable and enable the Automation for Jira to check if this resolves the issue
  • Clear plugin cache
  1. Stop the JIRA instance.
  2. Delete JIRA_HOME/plugins/. bundled-plugins and JIRA_HOME/plugins/. ...
  3. Restart JIRA.

 

Did NOT resolve the issue.

Update:

The issue is not solved.

 

Steps performed:

Set up JIRA in Safe Mode (disabling all rules)

 - Enable Jira Automation - Box is there

 - Enable all other apps, one by one, and testing always between enabling.

    Box disappears when enabling Time To SLA app.

 

Safe mode again.... same procedure...

 Box disappears after enable Time Status app.

 

Safe mode again... same procedure...

Box disappears after enable Plans (old portfolio app)

 

Safe mode again... same procedure...

Box disappears after Excentia app.

 

The behaviour is not the same, so sent to Atlassian the report and zip file.

 

Waiting for new troubleshooting steps.

 

Humberto

 

 

 

set up JIRA in Safe Mode using the MAnagem apps menu, 

Jack Community Leader Feb 24, 2021

Has Support responded to your updates?

Like John Funk likes this

Update:

 

Issus is not Solved.

 

Steps performed:

  • backup Jira
  • backup automation rules (export all rules )
  • uninstall A4J
  • ensure the plugin cache is cleared by following the below steps:
    Stop the JIRA instance.
    Delete JIRA_HOME/plugins/.bundled-plugins and JIRA_HOME/plugins/.osgi-plugins ( just these two folders!)
    Restart JIRA.
  • Reinstall A4J latest version 7.2.8 again.

 

Some notes:

- Backup Jira is only for just in case...

- Backup Rules did but not needed to import.

Jack Community Leader Feb 25, 2021

Thanks for keeping this thread updated @Humberto Gomes . This sure seems to be an ugly bug. 🤔

There is a temp fix (already done here).

Go to Safe Mode. (full safe mode)

Enable AFJ.

  active/deactivate the box  (it's available) as your need.

Back to normal setup. 

  the box will be available again but isn't configured.

 

The box still not visible for new rules and we can't go to "safe mode" every time.

Jack Community Leader Feb 25, 2021

🤮🤮🤮🤮

For now, with more tests, looks like the issue is in the app: Script Runner from Adaptavist

Starting with version 6.16

 

My findings:

ScriptRunner version 6.14 - No issue in A4J

ScriptRunner version 6.15 - No issue in A4J

ScriptRunner version 6.16 - issue in A4J

ScriptRunner version 6.17 - issue in A4J

ScriptRunner version 6.18 - issue in A4J

ScriptRunner version 6.19 - issue in A4J

ScriptRunner version 6.20 - (latest version available) -  issue in A4J

Like Kai Becker likes this

Can confirm that. The instance on which it still works uses ScriptRunner 6.05. None working instances uses ScriptRunner 6.16

Update:

 

Case raised to ScriptRunner owner:

 

"Thanks for reaching out to Adaptavist Support!
We are sorry you are experiencing this issue. There is a fixed Bug report for this here: SRJIRA-5012. It is currently in 'Awaiting Release' Status, meaning the Developers are finalizing the fix for public release."

Same issue with Jira 8.5.11, Automation Lite 7.2.1

Hi,

Do you have the app:

Script Runner?

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
SERVER
VERSION
8.15
TAGS
Community showcase
Published in Jira

Announcing the waitlist for Jira Work Management

Hey there Cloud Community members! We’re excited to give you the first glimpse of the new home for business teams on Jira — Jira Work Management. Jira Work Management is the next generation of J...

640 views 10 16
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you