Are you in the loop? Keep up with the latest by making sure you're subscribed to Community Announcements. Just click Watch and select Articles.

Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root


1 badge earned


Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!


Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.


Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!


Issue with switching Slack Workspaces for Atlassian Assist

Stephen Harding
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
Sep 21, 2023

Hello all,

I fear this issue is not something that can be resolved through the community, but I was advised by support that due to the account being in the free tier, my issue needs to be routed through here.

Alas, I decided to separate my Atlassian Assist chat functionality from the Slack workspace I had initially used for testing. It was originally under a "managers only" Slack workspace. I have now decided to create a new Slack workspace, dedicated to IT helpdesk ticket creation/questions.

As far as I could tell I did everything I could as far as removing ***OLD*** from the settings in Jira and Slack. I deleted the Slack Integration for that workspace as well as removed the Jira and Atlassian Assist Apps from that workspace.

However, after adding ***NEW*** to the Slack Integration section in Jira Service management project settings, when I go to the Channels>Chat then Configure, it automatically forces me to add Atlassian Assist back to ***OLD*** I tried to work around the issue by clicking the "Add to Slack" button on that page and then just changing the URL on the subsequent page to start with ***NEW***.com, which seemed to work. Unfortunately, when you go into the chat channel in the ***NEW*** Slack where the Atlassian bot should work, it doesn't activate/respond to commands.

Also, when you click on the Atlassian Assist App in the Apps section, it says

"This is still a work in progress

In the meantime, learn more about Atlassian Assist and what it can do by visiting the About tab."

I have removed and re-added the app several times just to test if it was a temporary issue, and perhaps the project settings in Jira would reflect my workaround attempt to link the Atlassian Assist App to the New Slack Workspace.

Has anyone encountered this and knows of a way to fix the issue?

Thanks in advance for any advice or assistance,


1 answer

0 votes
Evn Tomeny (Appfire)
Marketplace Partner
Marketplace Partners provide apps and integrations available on the Atlassian Marketplace that extend the power of Atlassian products.
Sep 22, 2023

Hey @Stephen Harding

Not a great answer, but I wanted to at least let you know that I have been trying to do this myself, and as far as I can tell, Atlassian Assist simply does not support this today. Nothing I've tried has allowed me to change the connected Slack Workspace once configured. If I do end up finding a way, I'll certainly come back here and let you know!

If it helps, since you're on the free tier, you should be able to use our app, HelpDesk+ for free. It includes the basic functionality available in Atlassian Assist and much more.

Evn from Appfire

Suggest an answer

Log in or Sign up to answer
Site Admin
AUG Leaders

Atlassian Community Events