Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Integration Opsgenie with Jira Service Management

Hi,

I followed this documentation guide https://support.atlassian.com/opsgenie/docs/integrate-opsgenie-with-jira-service-management/ and have set up both the Jira webhook and the Opsgenie Alert integration.

When I raise a test ticket in Jira, I do see from Opsgenie logs that it received the integration event but all the incomingData parsed object attribute fields have bank values and the warning I get is "Skipping incomingData, no matching actions found"

{ "_incomingData": { "_parsedData": { "summary": "null", "-components": [], "-labels": [], "reporter_email_address": "null", "project_key": "null", "created": "null", "comment_body": "null", "issue_type": "null", "description": "null", "webhookEvent": "issue_property_set", "statusCategory": "null", "priority": "null", "comment_author": "null", "assignee_email_address": "null", "delayIfDoesNotExists": "true", "alias": "null", "assignee_display_name": "null", "key": "null", "-versions": [], "reporter_display_name": "null", "status": "null" }, "integrationType": "JiraServiceDesk", "integrationName": "Jira Service Management", "incomingDataId": "db939e5e-1aa8-4db8-b570-83bfdc821df0", "key": "null" } }

I'm not sure if the problem is on the Opsgenie side or Jira. Could Jira be posting an empty message payload to Opsgenie and hence Opsgenie ends up not able to parse the inbound message for relevant key fields?

Thanks in advance for any help here.

Best regards

 

1 answer

0 votes
Prince Nyeche Community Leader May 21, 2021

Hi

Based on the document for successful connection, you have to input your email address and API token of your user for your JSM cloud instance. Did you do that? If yes, ensure that the project key you're trying to fetch data from is correct and is in capital letters.

I ended up figuring out that was the issue after posting my question on the board.

Thanks Prince for the assistance.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Jira Service Management

JSM June Challenge #2: Share how your business teams became ITSM rockstars

For JSM June Challenge #2, share how your non-technical teams like HR, legal, marketing, finance, and beyond started using Jira Service Management! Tell us: Did they ask to start using it or...

270 views 8 7
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you