Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

How do I import multiple object references into a single field?

Austin Jennings February 22, 2023

I have several Insight objects set up, and I’m trying to import my data into them. One is called “Environments” and another is called “Nodes”. An environment can be associated with multiple nodes, so I created a multiple select field which references nodes. I can add them manually without issue. However, when I try to import them from a CSV, it doesn’t add the node values to environments. 

Here’s the CSV format:

Environment Name, Designator

Abc environment, node 1||node 2||node 3

 

And here’s my IQL statement:

Designator = ${Designator}

 

Based on another answer to a very similar sounding problem, I also tried the following:

Department IN (${Department${0}})

And that successfully imported one node for each environment, but not all of them. I tried removing the ${0} and that just brought me back to no nodes at all. 

If I change the field type I’m importing this into to a simple select field (not an object reference) this import works flawlessly. But, I need it to be a reference. 

For even more context, I have another object “POC” which also references my “Node” object, but it’s a 1:1 relationship. I was able to execute an import with no issues there. It seems to only be when I’m trying to import multiple object references to a single field. 

3 answers

0 votes
Richard Jenkins February 16, 2024

For multiple references, use double pipes "||" as the concatenation character in the CSV file. Then, when you set up the import and edit the mapping, use the same double pipes in the Concatenator column.

triumph.png

Keep in mind, that the column "Data Source Field" is for the headers in the CSV file and it is the value referenced in the AQL along with the object attribute:

<object attribute> IN (${<data source field>})

0 votes
Richard Jenkins February 16, 2024

Looking for this answer as well. I, too, am running into the same issue where it is not adding the additional references. I only get the first one.

0 votes
Ulrich Kamp February 22, 2023

It works for me exactly with your import phrase.

But I once had the same problem: Then I forgot to change the destination attribute (the first "Department" in your case) with Cardinality type to "Unlimited" (screenshot only in German).

unlimited.png

Austin Jennings February 22, 2023

Thanks for the tip, unfortunately I had already checked “unlimited” so that’s not it either :/

Suggest an answer

Log in or Sign up to answer
TAGS
AUG Leaders

Atlassian Community Events