Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

How can I send an Approval notification when an agent sets the Approver Edited

We have a specific Issue Type that requires approval prior to beginning any work. The Approver is determined by the agent and entered after the request is received and has automatically entered the "Waiting for approval" status.

Depending on your use case, there are 3 ways to configure the user picker custom field that you selected on your approval step.

3. You want your agents to specify the approvers - This is useful if the customer doesn't know the approver, and the approver depends on the information on the request. In this case, the agent will need to review the request, and manually add an approver. View the request in your service project, and the user picker custom field is displayed in the People section of the request. You can make any changes you need to make inline. Note that there is also an Approval section that lists all approvers, however you can't make any edits here. If the field isn't showing, you may need to get a Jira administrator to check the field is still available on your project screens.

https://confluence.atlassian.com/adminjiraserver/configuring-jira-service-management-approvals-938847527.html

On the Agent View, the request is "Waiting for Approval" with a a message, "Add approver". Once an approver is added, the message changes to, "1 approval needed."

However, the approveal email notification is not sent to the approver because the Approvers field is set AFTER the request enter the approval state.

Problem

When a Service Management request transitions to an approval status, the approval notification is not sent to the approver(s) although it should.

  • Root cause 4:
    • The Approvers field was not set before the request transitioned to the status that requires an approval

Diagnosis

  • Root cause 4:
    • For the approval notification to be sent, it is required that the Approvers field is set before the request enters the Approval status

Resolution

Make sure that the Approvers field is always set before the request enters the Approval status (by ensuring that it this field sent during the request creation from the portal)

https://confluence.atlassian.com/jirakb/the-approval-notification-is-not-sent-when-a-service-management-request-is-waiting-for-an-approval-1031835729.html

 

How can I send a notification email to the Approver when using the option to allow Agents to set Approvers?

1 answer

1 accepted

0 votes
Answer accepted
Cody Stevens Community Leader Jul 19, 2021

Hey Greg,

This solution won't look as nice as the regular Atlassian generated emails and it won't have the option to approve or decline in the email but you can make an automation that triggers when the approver's field is edited that will send an email to the approver. 

 

Screen Shot 2021-07-19 at 12.14.23 PM.png

Hi Cody,

Thanks for offering up that solution. Unfortunately, in this particular case we require the default Atalassian generated email with the Approve/Decline buttons embedded (no login required).

Hey Greg,

I just tested this in my cloud instance and when I add a new approver to the approver's field, the new approver gets an email. I even removed the approver and readded them and the email was sent again. Are you 100% sure those emails aren't being sent? 

They may be going into their junk/spam folders but it appears that they are being sent. The articles you referenced are for server and you said you are on cloud. Is that correct? 

Hi Cody,

Well that's a bit of good news/bad news...!

I now know that the option is there to work they way I need it to, but it may be that something on my end is not configured properly.

I went through and tested a few different scenarios and here's what I found:

  • If I select the option to "Get Approvers From" -  <Approvers field>  within the

    Configure approval setting within the Workflow, then go to the Agent screen, I can select one of our licensed users and they WILL receive the notification email. Any non-licensed users WILL NOT receive an email.

  • If I select the option to "Get Approvers From" - <a custom field> which returns all active users, then go to the Agent screen, I CANNOT select any users. A message on the Agent screen states, "Only agents can add approvers"

Since I can see that licensed users are getting the email notifications, now my question is how can I allow for any (non-licensed) user to approve requests?

Thank you so much for having a look!

 

EDIT: After reading again through the Custom Field picker option (linked in original post), I realized the following applies:

Note that there is also an Approval section that lists all approvers, however you can't make any edits here. If the field isn't showing, you may need to get a Jira administrator to check the field is still available on your project screens.

I made the necessary change to add the custom field to the screen and now I am able to add the Approver from that field.

However, the email notification is still not being sent to anyone who is not a licensed user (customer).

Cody Stevens Community Leader Jul 19, 2021

The user I tested with is actually a customer only so I know non-licensed users can get the email. 

This probably isn't it but double-check that the notification is turned on. Assuming that it is, double-check the settings and make sure it's sending to the correct people. Follow this path to see if it's turned on or not. 

 

  1. Project Settings
  2. Customer Notifications

Screen Shot 2021-07-19 at 6.40.29 PM.png

It sounds like you are doing this right but just to be safe, make sure you are testing with an entirely different account and not your own. Sometimes JSM can get a bit weird if an agent makes a ticket and works on it as well. 

 

Also, since it appears only customers are not getting the emails, are they getting other notifications? 

I was able to run through some simple tests and after several hours I was not able to determine why non-licensed (customers) were not receiving the email notification. It was only after I thought about your question regarding other notifications when I realized that the issue is simply related to the Project Permissions which I have set. This particular project that I am testing in is a Dev project, and it's access is limited to only customers added by agents. So although my test customer existed, it was not one added by me (admin/agent). <slaps forehead>

However...

When I went into my live project to test my notifications, I found an issue related to the built-in Approvers field. For some unknown reason, the field is not associated with my Project and I have no clue as to how to rectify that.

When selecting "Approvers" as the field to get approvers from within the Workflow, the request is created without an option on the screen to add an approver. When using the "Find your field" (Agent view: Actions (ellipses) > Find your field > Approvers), I saw an issue in the Project and issue type scope (image attached). For whatever reason, only my DEV project is in the scope and I have no idea how to change that to include my live project. No issue there with my Custom Field that I created for approvals, but I cannot figure out how to get the Approvers field to work with my live project. The live project isn't even available as a choice if I wanted to restrict it to a specific project, on the Dev one.. The "add it to the scope" instruction in the Details isn't the most helpful, and I couldn't find an answer anywhere online.

I really do appreciate all your help on this.

approversField.jpg

Cody Stevens Community Leader Jul 20, 2021

I think your approvers field may have a context set on it restricting it to only be visible in certain projects. 

 

You can view the context it has by going to custom fields, finding your field and then clicking the 3 dots on the right and selecting Contexts and default value

Atlassian Support Doc

Screen Shot 2021-07-20 at 10.31.23 AM.png

Once you are on that screen, it will either show that it is restricted to specific issue types and projects or its global all issues. If its locked to certain issue types and projects you can make it global again or just add the new issue type and project it needs to be visible in. 

Thanks for that tip. It actually led me to discover where the issue was originating.

I had added a new Configuration Scheme for Approvers where I had set the project to be the live Helpdesk instance. I was not aware that only one Configuration Scheme can be associated with a project. Therefore, the default scheme was only being applied to the Dev project.

Thank you so very much for your help. You helped with an educated second set of eyes!

Like Cody Stevens likes this
Cody Stevens Community Leader Jul 20, 2021

Oh, that's great, I am glad I could help! 

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
PRODUCT PLAN
STANDARD
TAGS
Community showcase
Published in Jira Service Management

Atlympic Event: Jira Service Managemnt

Hello Community!  Quick disclaimer: We are running a contest on Community (The Atlympics!) from July 23rd - August 8th of 2021. If you are interested in participating in this contest (prizes! ...

99 views 0 1
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you