Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,463,211
Community Members
 
Community Events
176
Community Groups

How can I prevent comments on a closed issue?

I've added 

jira.permission.comment.denied=true

to the closed status on the workflow according to https://community.atlassian.com/t5/Jira-Software-questions/how-can-i-disable-comment-from-closed-issues-for-Jira-7-10/qaq-p/1017551 but customers are still able to comment on the issues. Does anyone have a working solution for this on Jira 8.x and JSD 4.3.x? Thanks! 

5 answers

2 accepted

1 vote
Answer accepted

Hi,

I just tested this out on my Jira.  And it worked perfectly.  On status "Closed" add property:

image.png

 

 

The property looks like this:

image.png

I tested trying to add a comment both from Jira and from the portal.  In both cases the comment option was not available

Like Ashraf B likes this

The property: 

jira.issue.editable=false 

 worked.

Would anybody know a way to still allow internal comments, but block public comments on an issue once it's closed? 

 

jira.permission.comment.user and a Property Value of false worked for me, but internal comments would be nice to still add.

 

(If anybody knows another discussion about this, please let me know!)

Thanks in advance :) 

Hey, did you resolve your issue? How to allow making only internal comments in closed issues?

Hi,

I followed the link and maybe that property doesn't work.

See this:

https://confluence.atlassian.com/jirakb/how-to-deactivate-comments-for-closed-issues-648217599.html?_ga=2.140725362.1789039137.1568638276-593356607.1541103302

 

JIRA 6.1.x

Add the property jira.permission.comment.user and make the property value false

 

Hope that helps

Susan

Remember to Publish your workflow after you've changed the properties. The change doesn't come into effect until then and it caught me out when I tested it.

For the Cloud version I used a Property Key of jira.permission.comment.user and a Property Value of false and was successful (once I'd published the change)

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events