Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,363,064
Community Members
 
Community Events
168
Community Groups

Email Requests in Service Desk not working

I'm trying to setup the email channel so that my Service Desk customers can email in an issue, and reply to email notifications to update their ticket. The email account in question is a gmail account. 

I've tried troubleshooting everything the docs suggest: 

- Tested the email connect (no errors, jira tells me it can connect to my gmail account successfully) 

- Customer settings are all correct - customers can create their own accounts, submit requests via emails etc

- Request type is setup & can be selected (only has 2 fields, Summary and description, both required) 

I email the email address in question and simply, nothing comes through to Jira. When I setup the email address I also didn't get the test that the documentation describes. 

Any ideas? I'm at a loss here - I've also tried disconnecting and reconnecting the email account, to no change. 

2 answers

1 accepted

1 vote
Answer accepted

Update - minutes after I posted this, I found the answer - our Global Mail Settings at a system level was set to not pull from email inboxes !

@Nicola Catton What setting is that? Can you be more specific? I'm having the same problem.... :( Thanks!

I found the setting - But it was already on for me, so this did not help. I still cant get emails through :(

 

Screen Shot 2017-09-12 at 2.34.44 PM.png

and finally figured it out... details here. https://community.atlassian.com/t5/Jira-Service-Desk-questions/Email-Requests-in-Service-Desk-not-working-v2/qaq-p/638922#U638936

 

It was due to a user being removed, but all the issue types were still being assigned to the user so Jira just stopped creating the issues. What perfectly expected functionality (SERIOUSLY???).

I was having a similar issue.  It appears the default mail handler will not create issues.  See Create issues and comments from email | Atlassian Support.

 

  1. Started by creating a new email handler ( Settings > System > Incoming Mail > Add incoming mail handler) with a new meaningful name
  2. Set Mail Handler Type to "Create a new issue or add a comment to an existing issue"
  3. Left the Folder name blank to process the inbox
  4. On the next screen I set several optional settings that I don't think had anything to do with the issue:
    1. I picked the project for my service management
    2. I set the Issue Type to "[System] Incident"
    3. I checked the box to Strip Quotes
    4. I specified the Catch Email Address as the address I used in Email Requests
    5. For Bulk, I left it "Ignore the email and do nothing"
    6. I set Forward Email to my email address to monitor for any errors
    7. I clicked the box to Create Users (as I understand it only creates portal customers and does not count against your licensed users)
    8. I also checked Notify Users, CC Assignee, and CC Watchers
  5. Next, I updated the Email Requests settings for the project ( Settings > Projects > More ... beside project > Project Settings > Email Requests )
  6. I started fresh by clicking the More (...) button in the top right and selecting "Disable all email requests"
  7. Click the "Turn on email support" button to create the default email account, support@{site}.atlassian.net
  8. I clicked Other button under "Connect a custom email account"
  9. Enter settings for email server ( email, password, mail server, and protocol) then click save

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events