Create security levels for issues via automation rule

Marek March 6, 2024

Hi all,

I can manually set security level per case; however, the automation rule keeps failing with the following error:

 

Action details:

JQL condition
The following issues passed:
TEST-445
Edit issue
No fields or field values to edit for issues (could be due to some field values not existing in a given project):
TEST-445
What Am I missing? I don't want agents to set security level. I want to have security level set per issue type. Please, let me know what permissions are needed for the "Automation for Jira" actor and where to set them. Thank you,

2 answers

1 vote
Mikael Sandberg
Community Leader
Community Leader
Community Leaders are connectors, ambassadors, and mentors. On the online community, they serve as thought leaders, product experts, and moderators.
March 6, 2024

Make sure that the project role atlassian-addons-project-access is added to both the security levels in your issue security scheme and that it has been added to the Set Issue Security in your permission scheme for the project.

Marek March 7, 2024

Here are the permissions for Set Issue Security:

  • Project Role (Administrators)
  • Project Role (Service Desk Team)
  • Project Role (atlassian-addons-project-access)
  • Service Project Customer - Portal Access

And the Security Level:

  • Group (Test-IT cases)
  • Group (site-admins)
  • Project Role (atlassian-addons-project-access)
0 votes
Ponnappan Ganapathiya March 7, 2024

No fields or field values to edit for issues (could be due to some field values not existing in a given project): - This error gives you that the value you provided to set is not in the options for 'Security Level' field(if the field is available) on the given project.

 

Could you please validate the the option is available in the project.

Project settings->Issue Security. If the option is not available then add it or Change the issue security scheme.

Marek March 7, 2024

Security Level field was added to appropriate screens and once a case is open, as agent, I can set security level to Test-IT Help.

Under Project Settings -> Issue Security, correct issue security scheme is selected, and Security Level is listed there as expected.

Anything else I need to check and/or re-configure? Thank you,

Ponnappan Ganapathiya March 7, 2024

Did you try changing the rule Actor to yourself?

Marek March 8, 2024

I pretty much followed this guide: Automation | Set "Issue Security Level" via Automation for JIRA | Automation for Jira | Atlassian Documentation

  • The Actor of the Automation Rule (By Default: Automation for JIRA) needs to be a member of the target Security Level. The Automation for Jira is not a general user as we see in the "User Management" page. Hence, we need to add the "Project Role (atlassian-addons-project-access)" to the security scheme.
  • The Actor of the automation rule needs to have the below permissions:
    • "Browse Projects" Permission
    • "Edit Issue" Permissions
    • "Set Security Level" Permission
  • The "Security Level" field needs to be added to the "Edit" and "View" Issue Screens from the Screen configuration of the Project.
Marek March 8, 2024

I also changed the actor to myself, and it failed with same error. 

Marek March 8, 2024

This Project Role (atlassian-addons-project-access), is already added in project permissions to browse, edit and set security level. It's also added to the security level.

What else I need to check?

Ponnappan Ganapathiya March 10, 2024

lets give a try with Trigger. Change it to manual trigger without JQL condition and try once. 

Create a issue and change the project level manually. Then reset the project level to default and try to change it via manual trigger.

 

Possibly the JQL condition may restrict the field edit option. 

 

Even after the problem persists, create a support ticket.

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
PRODUCT PLAN
STANDARD
PERMISSIONS LEVEL
Site Admin
TAGS
AUG Leaders

Atlassian Community Events