Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
Level
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Change Default 'Share with Group' to 'No one'

The default in service desk for when a ticket is created seems to be "Share with (Group Name".  Is it possible to set this default to 'Share with No One'

3 answers

0 votes
Jack Community Leader Sep 24, 2018

@Craig Doran, what do you mean by share with group? Are you saying that a group of users are added to the watchers or participant fields or something else. There isn’t any default to do this so I suspect that maybe there is some configuration or automation set up in your project. But I may be missing you point here.

Hi Jack

I have a group of customers all added to a GROUP.

When one customer creates a request at the bottom of the request ticket there is Share With option.  It is defaulted to Share with group but customer can use drop down list to Share With No One.  I find that customers in a group don't necessarily want to get everyone elses request tickets.  But unless each customer changes this default share with setting, they each get the ticket

Jack Community Leader Sep 24, 2018

Ok so yes that is associated with the Participant field. Check to see if the field is set with a default as follows: project > project settings > request types and edit fields on one of the request types to see if share with is listed and defaulted.

Hi Jack. Yes I had already looked there but the share field does not appear when you select Edit Fields against a request type

Jack Community Leader Sep 25, 2018

Craig, thanks for hanging in there. I just did a bit of research into the docs and below is what I found. So in fact it appears you cannot change the default unless you were to have the customer in more than one Organization. I was thrown off a bit by the "group" term and am assuming you are using Organizations. When I saw group i was guessing you might have a custom drop down field but it seems that this is the standard Participation field. Please let me know if this is on the right track.

from this document...

Add participants in the portal

In the customer portal, agents and customers can add participants by selecting Share. Participants receive an email notifying them that they are participating in the 

If a customer is in an organization, they can also share the request when they raise it. By default, the request is shared with the customer's organization unless they select Private request.

If the customer is in more than one organization, the request is private by default.

Hi... I recently added in a number of customers into 2 separate organizations since their  'Share With Organization' field was not set to Private.  However, since adding them into a new organization, the recent organization I just created is now populated by default, not private.  Any suggestions?

 

Thanks

Hello, about the option to share the ticket with other users, it turns out that by default when we are creating tickets, it is shared with a default user different from the creator, for example it is shared with client1, and when we delete that user (client1), we no longer allows creating tickets and shows error because it cannot find the user with whom it is shared by default. Could you please help me see where I should check to remove the default user. Thank you

0 votes

Hi Craig, I believe this has since been fixed. 

You can now change the default value for whom the ticket is shared with from being the Organisation of the customer to "No one".  The easiest way to do that is to go to "Project settings"> "Customer permissions" and then click on the hyperlink that says "Change the Global settings". 

Screen Shot 2021-02-25 at 10.54.43 am.png

Then, you can change the "should new requests automatically be shared with a customer's organization?" to "No, don't share . . .". This then changes the default value in the share with.

Screen Shot 2021-02-25 at 10.52.41 am.png

Does this solve your problem? The final output is that it defaults to "No one".

Screen Shot 2021-02-25 at 10.55.43 am.png

Thanks,

 

Jehan

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Jira Service Management

Announcing Mindville Insight is now part of Jira Service Management!

Hello Community! We’re excited to announce that Mindville Insight’s asset and configuration management capabilities will now be integrated into Jira Service Management Premium and Enterprise plan...

736 views 12 15
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you