Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,464,407
Community Members
 
Community Events
176
Community Groups

Cannot create automation rule for my project

Hello,

 

I'm currently using the Cloud free Jira Service Management and try to set it up before migrating our teams to this new tool. I'm clearly a newbie with Jira.

I want to create an automation rule that will update a custom field when the issue is created. The goal is to compute an URL based on the issue ID.

 

After creating, a new automation rule for my project, I'm trying to publish it and I have the following error:

"

There was a problem retrieving permissions from your Jira instance. Please try publishing this rule again.

"

I can retry and retry again I always have the same error and the rule is not published.

 

The exact same rule can be added as a gloabal automation rule but it does not get executed for my project. If I try to change the scope of this rule from the global automation rule screen to the scope of my project I get the exact same error above.

 

Any solution?

 

Thank you,

Guillaume

3 answers

We are also experiencing this issue. There was a problem retrieving permissions from your Jira instance. Please try publishing this rule again.

 

I have checked permissions and I have sufficient privileges to do the automation setup

Hi David,

 

Unfortunately it was not. I'm discussing with Atlassian to get support on this.

 

Best regards,

Guillaume

@Guillaume Gaudonville 

 

Have you already checked the permissions schemes for your project?

Do the following:

Access the project settings and click on "People", add your user in the project role "administrators".

Then go back in the project settings and see "Permissions", ensure that the project role "administrators" and "addons" are included in "browse project" and in "Edit issue".

If this is corrected, please bring us a screenshot of your automation framework for us to evaluate.

Hi Fernando,

My user has already the project role administrators. Role administrators is already included in "browse project" and "Edit issue".

By the way, I did not modify the permission scheme for my project, so it is inherited from the default "demo" project created when I started to play with Jira service management.

Please find attached the screenshot. Here I'm trying to add the automation rule from the global automation screen with a scope limited to my project. Same happens when trying to add an automation rule directly from my project's automation screen.

Thank you,2022-02-18_11-08.png

Like Lakshyajeet Swami likes this

In this case, I recommend that you contact Atlassian support to evaluate.

If your user has all the profiles and permissions, this error seems to be a bug of the system not recognizing your permissions.

The support ticket you can open here: https://support.atlassian.com/contact/#/

Thank you Fernando.

 

Unfortunately while I'm still on the Cloud free version I cannot open support request.

Can you verify if this behavior is repeated in another project?

If it doesn't happen in another project, you can create a new project by copying the structure of the current one, so you don't lose all the details.

Yes same problem. I contacted the support to extend my free trial and talk to them about the issue, I'll see what they can do.

 

Thank you very much for your help.

You're welcome! I hope they can get this resolved soon. Have a good day

Hi Fernando,

I am having a similar issue with automations I migrated from one instance to another. Was your issue resolved and if yes, how?

Thanks!

Hi David,

I too am having this issue with automation, I too migrated from one instance to another. 

Have you got any answer, David? was the problem for u resolved? If yes can u Guide me?

Thanks.

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events